aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2021-12-05 12:06:12 +0100
committerFlorian Schmaus <flow@gentoo.org>2021-12-05 12:06:12 +0100
commitf74dfb0ac5e7cfba70811c910400ca9c827bd9ec (patch)
treedcc14c4601b733967992e8f544aa82579187447b
parentdev-java/jamvm: update to EAPI 6 (diff)
downloadjava-f74dfb0ac5e7cfba70811c910400ca9c827bd9ec.tar.gz
java-f74dfb0ac5e7cfba70811c910400ca9c827bd9ec.tar.bz2
java-f74dfb0ac5e7cfba70811c910400ca9c827bd9ec.zip
dev-java/cacao: update to EAPI 6
Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--dev-java/cacao/cacao-1.6.0-r4.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/dev-java/cacao/cacao-1.6.0-r4.ebuild b/dev-java/cacao/cacao-1.6.0-r4.ebuild
index 8b57d2b5..e509dffc 100644
--- a/dev-java/cacao/cacao-1.6.0-r4.ebuild
+++ b/dev-java/cacao/cacao-1.6.0-r4.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
+
AUTOTOOLS_AUTO_DEPEND="no"
inherit autotools eutils flag-o-matic java-pkg-2 java-vm-2
@@ -26,14 +27,18 @@ DEPEND="${COMMON_DEPEND}
)
"
+PATCHES=(
+ "${FILESDIR}/system-boehm-gc.patch"
+ "${FILESDIR}/support-7.patch"
+)
+
src_prepare() {
+ eapply_user
if use test; then
sed -ie "s:/usr/share/java/junit4.jar:$(java-config -p junit-4):" \
./tests/regression/bugzilla/Makefile.am \
./tests/regression/base/Makefile.am || die "sed failed"
fi
- epatch "${FILESDIR}/system-boehm-gc.patch"
- epatch "${FILESDIR}/support-7.patch"
eautoreconf
}
@@ -50,10 +55,6 @@ src_configure() {
--with-jni_md_h="${EPREFIX}"/usr/include/classpath
}
-src_compile() {
- default
-}
-
src_install() {
local libdir=$(get_libdir)
local CLASSPATH_DIR=/usr/libexec/gnu-classpath