summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-04-27 10:25:12 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-04-27 17:15:44 +0200
commit0cdb787dbac6bb89cd1dfc706687c1ad151a07ec (patch)
treeefd707c3bff00b74fbba1804eb62c8051a581396
parentdev-util/automoc: EAPI-7 bump, switch to cmake.eclass (diff)
downloadkde-sunset-0cdb787dbac6bb89cd1dfc706687c1ad151a07ec.tar.gz
kde-sunset-0cdb787dbac6bb89cd1dfc706687c1ad151a07ec.tar.bz2
kde-sunset-0cdb787dbac6bb89cd1dfc706687c1ad151a07ec.zip
dev-libs/qjson: EAPI-7 bump, switch to cmake.eclass
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-libs/qjson/qjson-0.9.0.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-libs/qjson/qjson-0.9.0.ebuild b/dev-libs/qjson/qjson-0.9.0.ebuild
index c81aac1d..030411f8 100644
--- a/dev-libs/qjson/qjson-0.9.0.ebuild
+++ b/dev-libs/qjson/qjson-0.9.0.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+CMAKE_ECLASS=cmake
inherit cmake-multilib
DESCRIPTION="Library for mapping JSON data to QVariant objects"
@@ -37,14 +38,14 @@ multilib_src_configure() {
-DQJSON_BUILD_TESTS=$(usex test)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
multilib_src_install_all() {
if use doc && is_final_abi; then
pushd doc > /dev/null || die
doxygen Doxyfile || die "Generating documentation failed"
- HTML_DOCS=( doc/html/. )
+ local HTML_DOCS=( doc/html/. )
popd > /dev/null || die
einstalldocs
fi