summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-12-07 20:57:39 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-12-07 20:57:39 +0100
commit2814f590ed19db8dd4b2d3f61346b03767ada288 (patch)
tree0ef2f55f06157d007b8d2bdd599a84194ad5de2a
parentapp-dicts/qvortaro: Port to EAPI-7, qmake-utils, xdg eclass, fix SRC_URI (diff)
downloadkde-sunset-2814f590ed19db8dd4b2d3f61346b03767ada288.tar.gz
kde-sunset-2814f590ed19db8dd4b2d3f61346b03767ada288.tar.bz2
kde-sunset-2814f590ed19db8dd4b2d3f61346b03767ada288.zip
x11-misc/ptbatterysystemtray: Port to EAPI-7, qmake-utils, xdg eclass
Fix HOMEPAGE, SRC_URI Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--x11-misc/ptbatterysystemtray/Manifest2
-rw-r--r--x11-misc/ptbatterysystemtray/ptbatterysystemtray-1.0.0_rc2.ebuild21
2 files changed, 14 insertions, 9 deletions
diff --git a/x11-misc/ptbatterysystemtray/Manifest b/x11-misc/ptbatterysystemtray/Manifest
index 1e1566e3..cf82a8dd 100644
--- a/x11-misc/ptbatterysystemtray/Manifest
+++ b/x11-misc/ptbatterysystemtray/Manifest
@@ -1 +1 @@
-DIST ptbatterysystemtray-1.0.0_rc2.tar.gz 234884 BLAKE2B e0e35440ae2db843150f73d5f4e7a118ddc71e185ed3471ddffc8524a92866c503ad7242402ec8080befe4f56d52a25aab5856026aa0f08369d599a9864d16ef SHA512 869eb71032691738277c1ba16b9e8d6e79ab25e8c533c2c12b4a69c6dbfee53d40bb471e4d28ce60b9e3dae19aea166953b5d5641ae0ba873ef55811fdd088e5
+DIST ptbatterysystemtray-1.0.0.rc2.tar.bz2 231912 BLAKE2B fc03a5ab9fdfa3356f4adc39921a7828a70d5587dc4342c64ef21d412b6c2eb8f8fb279c786695882ad2a3c3659eb7e32ff6cab591a1aaa31fcee563660b2ec6 SHA512 ac6dd76f22b168c1594729e1d5dc5434bf3455e919a577a2d922e7bc9a4ae79034aba46b82d8d0da1b840546c902c452af7d7b0c44cfaa5b72f689400c5504cd
diff --git a/x11-misc/ptbatterysystemtray/ptbatterysystemtray-1.0.0_rc2.ebuild b/x11-misc/ptbatterysystemtray/ptbatterysystemtray-1.0.0_rc2.ebuild
index 37c6361a..d4b3ee2e 100644
--- a/x11-misc/ptbatterysystemtray/ptbatterysystemtray-1.0.0_rc2.ebuild
+++ b/x11-misc/ptbatterysystemtray/ptbatterysystemtray-1.0.0_rc2.ebuild
@@ -1,12 +1,14 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit qt4-r2
+EAPI=7
+
+inherit qmake-utils xdg
DESCRIPTION="A simple battery monitor in the system tray"
-HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
-SRC_URI="mirror://gentoo/${P}.tar.gz"
+HOMEPAGE="https://sourceforge.net/projects/batterysystem/"
+SRC_URI="http://ponce.cc/slackware/sources/repo/${P/_/.}.tar.bz2"
+S="${WORKDIR}/${P/_/.}"
LICENSE="GPL-3"
SLOT="0"
@@ -20,13 +22,16 @@ DEPEND="
"
RDEPEND="${DEPEND}"
-DOCS="AUTHORS ChangeLog README"
-
-src_unpack() {
+src_prepare() {
default
- mv ${PN}-${PN} "${S}" || die
+ sed -e "/^Categories/s/Application;//" -i ptbatterysystemtray.desktop || die
}
src_configure() {
eqmake4 ${PN}.pro INSTALL_PREFIX=/usr
}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}