aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-10-08 18:03:04 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-10-08 18:59:24 +0200
commit041658e1d0a9ad8baa6deb9c8b27d4070b584b42 (patch)
treeb6f45bb517559494ca7245145f96b04b5cc3f6b4 /dev-build
parentkde-misc/zanshin: 24.08.2 version bump (diff)
downloadkde-041658e1d0a9ad8baa6deb9c8b27d4070b584b42.tar.gz
kde-041658e1d0a9ad8baa6deb9c8b27d4070b584b42.tar.bz2
kde-041658e1d0a9ad8baa6deb9c8b27d4070b584b42.zip
dev-build/dolphin-plugins-makefileactions: 24.08.2 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-build')
-rw-r--r--dev-build/dolphin-plugins-makefileactions/Manifest1
-rw-r--r--dev-build/dolphin-plugins-makefileactions/dolphin-plugins-makefileactions-24.08.2.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-build/dolphin-plugins-makefileactions/Manifest b/dev-build/dolphin-plugins-makefileactions/Manifest
new file mode 100644
index 0000000000..d23d32d9b2
--- /dev/null
+++ b/dev-build/dolphin-plugins-makefileactions/Manifest
@@ -0,0 +1 @@
+DIST dolphin-plugins-24.08.2.tar.xz 317744 BLAKE2B 5ea4755bee6d5ec3a3dbb30e1afe290818bdb57e14421fbb9a907f8f791e6001eef8cf134ec3d9415ca43824153bf55096f8f3e1ee2434a58795da979957a2db SHA512 c89a7a6d9f1a2d567522e126e25b52290205f96166ceb9b95c8aa0fbcf28424891ed1e60a1cdd4b158fd4ed48bb3b7a6bcdb6c79fe712b1cbdeb13c0c275a1f5
diff --git a/dev-build/dolphin-plugins-makefileactions/dolphin-plugins-makefileactions-24.08.2.ebuild b/dev-build/dolphin-plugins-makefileactions/dolphin-plugins-makefileactions-24.08.2.ebuild
new file mode 100644
index 0000000000..10b6d67ba0
--- /dev/null
+++ b/dev-build/dolphin-plugins-makefileactions/dolphin-plugins-makefileactions-24.08.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="makefileactions"
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.5.0
+QTMIN=6.7.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Dolphin plugin for Makefile targets integration"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2+"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[concurrent,gui,widgets]
+ >=kde-apps/dolphin-${PVCUT}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kjobwidgets-${KFMIN}:6
+"
+RDEPEND="${DEPEND}
+ >=kde-apps/dolphin-plugins-common-${PV}
+"
+
+src_prepare() {
+ ecm_src_prepare
+ ecm_punt_po_install
+ # solid, qtdbus only required by mountiso
+ ecm_punt_qt_module DBus
+ ecm_punt_kf_module Solid
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_qt_module Network
+ ecm_punt_kf_module XmlGui
+ # kcompletion, ktextwidgets only required by other plugins
+ ecm_punt_kf_module Completion
+ ecm_punt_kf_module TextWidgets
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_mountiso=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}