aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-03-03 17:24:08 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-03-03 17:25:53 +0100
commitaf86b7244bf1c4335762fcf6fd5aed9735d5743f (patch)
tree52534272dd715a7fd2e6eeed893006e0cf7a0bec /dev-libs
parentmedia-libs/phonon-vlc: Use cmake.eclass and multibuild instead of ecm.eclass (diff)
downloadkde-af86b7244bf1c4335762fcf6fd5aed9735d5743f.tar.gz
kde-af86b7244bf1c4335762fcf6fd5aed9735d5743f.tar.bz2
kde-af86b7244bf1c4335762fcf6fd5aed9735d5743f.zip
dev-libs/plasma-wayland-protocols: Use cmake instead of ecm.eclass
The latter was just overkill for the needs of this simple build system, this ensures that it works for Qt5/Qt6 "purity" builds alike. Bug: https://bugs.gentoo.org/923502 Closes: https://github.com/gentoo/kde/pull/980 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/plasma-wayland-protocols/plasma-wayland-protocols-9999.ebuild22
1 files changed, 19 insertions, 3 deletions
diff --git a/dev-libs/plasma-wayland-protocols/plasma-wayland-protocols-9999.ebuild b/dev-libs/plasma-wayland-protocols/plasma-wayland-protocols-9999.ebuild
index 96a44c879a..05f74e583c 100644
--- a/dev-libs/plasma-wayland-protocols/plasma-wayland-protocols-9999.ebuild
+++ b/dev-libs/plasma-wayland-protocols/plasma-wayland-protocols-9999.ebuild
@@ -3,9 +3,7 @@
EAPI=8
-ECM_NONGUI=true
-KFMIN=5.115.0
-inherit ecm kde.org
+inherit cmake kde.org
DESCRIPTION="Plasma Specific Protocols for Wayland"
HOMEPAGE="https://invent.kde.org/libraries/plasma-wayland-protocols"
@@ -17,3 +15,21 @@ fi
LICENSE="LGPL-2.1"
SLOT="0"
+
+BDEPEND="
+ dev-libs/libpcre2:*
+ >=kde-frameworks/extra-cmake-modules-5.115.0:*
+ || (
+ dev-qt/qtbase:6
+ dev-qt/qtcore:5
+ )
+"
+
+ecm_src_configure() {
+ local mycmakeargs=(
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON # ecm.eclass
+ -DKDE_INSTALL_DOCBUNDLEDIR="${EPREFIX}/usr/share/help" # ecm.eclass
+ )
+
+ cmake_src_configure
+}