aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-08-09 21:59:29 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-08-09 22:01:25 +0200
commit28b6443dd559f1113d802408b236b59984d59ca5 (patch)
treee3d9de4721ed42358cbc94ad41c7679bbd6ae2eb /games-kids
parentkde-apps/gwenview: ccache option is obsolete already (diff)
downloadkde-28b6443dd559f1113d802408b236b59984d59ca5.tar.gz
kde-28b6443dd559f1113d802408b236b59984d59ca5.tar.bz2
kde-28b6443dd559f1113d802408b236b59984d59ca5.zip
games-kids/gcompris: New package (project moved to KDE)
This will need more work, but it builds for now. Package-Manager: Portage-2.3.45, Repoman-2.3.10
Diffstat (limited to 'games-kids')
-rw-r--r--games-kids/gcompris/gcompris-9999.ebuild38
-rw-r--r--games-kids/gcompris/metadata.xml15
2 files changed, 53 insertions, 0 deletions
diff --git a/games-kids/gcompris/gcompris-9999.ebuild b/games-kids/gcompris/gcompris-9999.ebuild
new file mode 100644
index 0000000000..d8b757ff20
--- /dev/null
+++ b/games-kids/gcompris/gcompris-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="optional"
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="Full featured educational application for children from 2 to 10"
+HOMEPAGE="http://gcompris.net/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS=""
+IUSE="kiosk"
+
+RDEPEND="
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtsensors)
+ $(add_qt_dep qtsvg)
+"
+DEPEND="${RDEPEND}
+ $(add_qt_dep linguist-tools)
+ $(add_qt_dep qtmultimedia)
+ $(add_qt_dep qtxml)
+ $(add_qt_dep qtxmlpatterns)
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DQML_BOX2D_MODULE=disabled
+ -DWITH_KIOSK_MODE=$(usex kiosk)
+ )
+ kde5_src_configure
+}
diff --git a/games-kids/gcompris/metadata.xml b/games-kids/gcompris/metadata.xml
new file mode 100644
index 0000000000..8d4ef553b6
--- /dev/null
+++ b/games-kids/gcompris/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <use>
+ <flag name="kiosk">Enable kiosk mode by default</flag>
+ </use>
+</pkgmetadata>