aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-03-29 16:40:54 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-04-26 17:20:38 +0200
commitcba79970f4530617c5f3fa5b68b6496f2e49a394 (patch)
treedacb13dd151fc49da75a6933f4061023d3527389 /gui-apps
parentapp-crypt/keysmith: Add missing dependency (diff)
downloadkde-cba79970f4530617c5f3fa5b68b6496f2e49a394.tar.gz
kde-cba79970f4530617c5f3fa5b68b6496f2e49a394.tar.bz2
kde-cba79970f4530617c5f3fa5b68b6496f2e49a394.zip
gui-apps/xwaylandvideobridge: new package, add 9999, 0_pre20230421
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/xwaylandvideobridge/Manifest1
-rw-r--r--gui-apps/xwaylandvideobridge/metadata.xml11
-rw-r--r--gui-apps/xwaylandvideobridge/xwaylandvideobridge-0_pre20230421.ebuild37
-rw-r--r--gui-apps/xwaylandvideobridge/xwaylandvideobridge-9999.ebuild36
4 files changed, 85 insertions, 0 deletions
diff --git a/gui-apps/xwaylandvideobridge/Manifest b/gui-apps/xwaylandvideobridge/Manifest
new file mode 100644
index 0000000000..7d504505d9
--- /dev/null
+++ b/gui-apps/xwaylandvideobridge/Manifest
@@ -0,0 +1 @@
+DIST xwaylandvideobridge-0_pre20230421-4a72e7c1.tar.gz 30899 BLAKE2B ce62beacbb332f929361d7f8faf8a862387629317f23d20d462759848c17f4f02bee2fa2e8a5563ab964db3101a7ca609118106ee219cb6dabfc42a4facc8f9a SHA512 109b24ec511b2d6d9ff67e344f4bc4a3c062e5547ff8db153e08aae49d17466df9499c0a0ae524a6dd3cd321fe2553c8a6f8549037d0b38d7620caa2ec4634ab
diff --git a/gui-apps/xwaylandvideobridge/metadata.xml b/gui-apps/xwaylandvideobridge/metadata.xml
new file mode 100644
index 0000000000..170f61584c
--- /dev/null
+++ b/gui-apps/xwaylandvideobridge/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="kde-invent">system/xwaylandvideobridge</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/gui-apps/xwaylandvideobridge/xwaylandvideobridge-0_pre20230421.ebuild b/gui-apps/xwaylandvideobridge/xwaylandvideobridge-0_pre20230421.ebuild
new file mode 100644
index 0000000000..afc48c219b
--- /dev/null
+++ b/gui-apps/xwaylandvideobridge/xwaylandvideobridge-0_pre20230421.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.102.0
+QTMIN=5.15.7
+KDE_ORG_CATEGORY="system"
+KDE_ORG_COMMIT="4a72e7c19884c5a87a2cbfcf01c5293199196e1e"
+inherit ecm kde.org
+
+DESCRIPTION="Screenshare Wayland windows to XWayland apps"
+
+if [[ ${KDE_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5=
+ >=kde-frameworks/ki18n-${KFMIN}:5=
+ >=kde-frameworks/knotifications-${KFMIN}:5=
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5=
+ >=kde-plasma/kpipewire-5.27.4:5
+ media-libs/freetype
+ x11-libs/libxcb:=
+"
+RDEPEND="${DEPEND}"
+
+BDEPEND="virtual/pkgconfig"
diff --git a/gui-apps/xwaylandvideobridge/xwaylandvideobridge-9999.ebuild b/gui-apps/xwaylandvideobridge/xwaylandvideobridge-9999.ebuild
new file mode 100644
index 0000000000..247dd6c4c6
--- /dev/null
+++ b/gui-apps/xwaylandvideobridge/xwaylandvideobridge-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.102.0
+QTMIN=5.15.7
+KDE_ORG_CATEGORY="system"
+inherit ecm kde.org
+
+DESCRIPTION="Screenshare Wayland windows to XWayland apps"
+
+if [[ ${KDE_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5=
+ >=kde-frameworks/ki18n-${KFMIN}:5=
+ >=kde-frameworks/knotifications-${KFMIN}:5=
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5=
+ >=kde-plasma/kpipewire-5.27.4:5
+ media-libs/freetype
+ x11-libs/libxcb:=
+"
+RDEPEND="${DEPEND}"
+
+BDEPEND="virtual/pkgconfig"