aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2012-11-03 03:55:52 +1100
committerMichael Palimaka <kensington@gentoo.org>2012-11-03 03:55:52 +1100
commit8da16be2b2f5174a4d0c5cf69a912a53ca627e2f (patch)
treed9ad58e23a8f72a9ac9d8828c76420a9325ed4bd /kde-base/kdeplasma-addons
parent[profiles/package.mask] Mask KDE SC 4.9.3. (diff)
downloadkde-8da16be2b2f5174a4d0c5cf69a912a53ca627e2f.tar.gz
kde-8da16be2b2f5174a4d0c5cf69a912a53ca627e2f.tar.bz2
kde-8da16be2b2f5174a4d0c5cf69a912a53ca627e2f.zip
[kde-base] Add KDE SC 4.9.3.
Note that l10n is not yet released. Package-Manager: portage-2.1.11.31
Diffstat (limited to 'kde-base/kdeplasma-addons')
-rw-r--r--kde-base/kdeplasma-addons/Manifest1
-rw-r--r--kde-base/kdeplasma-addons/kdeplasma-addons-4.9.3.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/kde-base/kdeplasma-addons/Manifest b/kde-base/kdeplasma-addons/Manifest
new file mode 100644
index 0000000000..5e7b342816
--- /dev/null
+++ b/kde-base/kdeplasma-addons/Manifest
@@ -0,0 +1 @@
+DIST kdeplasma-addons-4.9.3.tar.xz 1742856 SHA256 101d509c0701274da99f9e71d6016dc1d97439fb8100da53d9f58ffbe2a0debe SHA512 1549d38843811735597869066d7a7493cb2d6e337b33fd6ebd405d69e3c235310b89735a6e4018da58ba68460c70f26df27c169d1ea655729123fc047ec1b632 WHIRLPOOL 504247e45f552ef04c2bc77fbffee33bd6e662b4472ad326622293064430b8490b79a949939fd15ae3349f9f748e8b0c3a0bc52e4b63de476c398a6732a2196b
diff --git a/kde-base/kdeplasma-addons/kdeplasma-addons-4.9.3.ebuild b/kde-base/kdeplasma-addons/kdeplasma-addons-4.9.3.ebuild
new file mode 100644
index 0000000000..356766ce43
--- /dev/null
+++ b/kde-base/kdeplasma-addons/kdeplasma-addons-4.9.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit kde4-base
+
+DESCRIPTION="Extra Plasma applets and engines"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="attica debug desktopglobe exif fcitx ibus json oauth qalculate qwt scim
+semantic-desktop"
+
+# krunner is only needed to generate dbus interface for lancelot
+COMMON_DEPEND="
+ app-crypt/qca:2
+ app-crypt/qca-ossl:2
+ $(add_kdebase_dep kdelibs 'semantic-desktop=')
+ $(add_kdebase_dep krunner)
+ $(add_kdebase_dep plasma-workspace 'semantic-desktop=')
+ x11-misc/shared-mime-info
+ attica? ( dev-libs/libattica )
+ desktopglobe? ( $(add_kdebase_dep marble) )
+ exif? ( $(add_kdebase_dep libkexiv2) )
+ fcitx? ( app-i18n/fcitx[dbus(+)] )
+ ibus? ( app-i18n/ibus )
+ json? ( dev-libs/qjson )
+ oauth? ( dev-libs/qoauth )
+ qalculate? ( sci-libs/libqalculate )
+ qwt? ( x11-libs/qwt:5 )
+ scim? ( app-i18n/scim )
+ semantic-desktop? (
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop')
+ $(add_kdebase_dep plasma-workspace 'rss')
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-cpp/eigen:2
+"
+RDEPEND="${COMMON_DEPEND}
+"
+
+src_configure() {
+ mycmakeargs=(
+ -DDBUS_INTERFACES_INSTALL_DIR="${EPREFIX}/usr/share/dbus-1/interfaces/"
+ $(cmake-utils_use_with attica LibAttica)
+ $(cmake-utils_use_with desktopglobe Marble)
+ $(cmake-utils_use_with exif Kexiv2)
+ $(cmake-utils_use_with ibus)
+ $(cmake-utils_use_with json QJSON)
+ $(cmake-utils_use_with oauth QtOAuth)
+ $(cmake-utils_use_with qalculate)
+ $(cmake-utils_use_with qwt)
+ $(cmake-utils_use_with semantic-desktop KdepimLibs)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with scim)
+ )
+
+ kde4-base_src_configure
+}