aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-01-18 00:43:11 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2009-01-18 00:43:11 +0300
commitf1e3e1e9a522282bc989ff9baa16a423770ad10b (patch)
tree56532c88ceed9164d402138cd4f327d411735fa0 /kde-base/konsole/konsole-9999.ebuild
parentktorent moved to tree (diff)
downloadkde-f1e3e1e9a522282bc989ff9baa16a423770ad10b.tar.gz
kde-f1e3e1e9a522282bc989ff9baa16a423770ad10b.tar.bz2
kde-f1e3e1e9a522282bc989ff9baa16a423770ad10b.zip
Add kde-crazy files to kde-testing
Diffstat (limited to 'kde-base/konsole/konsole-9999.ebuild')
-rw-r--r--kde-base/konsole/konsole-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/kde-base/konsole/konsole-9999.ebuild b/kde-base/konsole/konsole-9999.ebuild
new file mode 100644
index 0000000000..c5254fbd17
--- /dev/null
+++ b/kde-base/konsole/konsole-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+KMNAME="kdebase-apps"
+inherit kde4-meta
+
+DESCRIPTION="X terminal for use with KDE."
+KEYWORDS=""
+IUSE="debug htmlhandbook"
+
+COMMONDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ >=x11-libs/libxklavier-3.2
+ x11-libs/libXrender
+ x11-libs/libXtst
+"
+DEPEND="${COMMONDEPEND}
+ x11-apps/bdftopcf
+ x11-proto/kbproto
+ x11-proto/renderproto
+"
+RDEPEND="${COMMONDEPEND}"
+
+src_unpack() {
+ if use htmlhandbook; then
+ KMEXTRA="${KMEXTRA} doc/${PN}/"
+ fi
+
+ kde4-meta_src_unpack
+}