aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2013-07-15 17:27:41 +0400
committerAlexey Shvetsov <alexxy@gentoo.org>2013-07-15 17:27:41 +0400
commitfe82c34c3fce95a4ee0fa8d2290aafda392721a2 (patch)
treef95ac918cd7cb0097935f5ea4dc2d380dcf23392 /kde-base/kwin/kwin-4.10.49.9999.ebuild
parent[kde-base/okteta] Remove failing patch wrt bug #476676. (diff)
downloadkde-fe82c34c3fce95a4ee0fa8d2290aafda392721a2.tar.gz
kde-fe82c34c3fce95a4ee0fa8d2290aafda392721a2.tar.bz2
kde-fe82c34c3fce95a4ee0fa8d2290aafda392721a2.zip
[kde-base] Add 4.11 rc1 and drop 4.10 branch
Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'kde-base/kwin/kwin-4.10.49.9999.ebuild')
-rw-r--r--kde-base/kwin/kwin-4.10.49.9999.ebuild73
1 files changed, 0 insertions, 73 deletions
diff --git a/kde-base/kwin/kwin-4.10.49.9999.ebuild b/kde-base/kwin/kwin-4.10.49.9999.ebuild
deleted file mode 100644
index 20d62c4a7c..0000000000
--- a/kde-base/kwin/kwin-4.10.49.9999.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=5
-
-KMNAME="kde-workspace"
-DECLARATIVE_REQUIRED="always"
-OPENGL_REQUIRED="always"
-inherit flag-o-matic kde4-meta
-
-DESCRIPTION="KDE window manager"
-KEYWORDS=""
-IUSE="debug gles opengl"
-
-COMMONDEPEND="
- $(add_kdebase_dep kactivities)
- $(add_kdebase_dep kdelibs opengl)
- $(add_kdebase_dep kephal)
- $(add_kdebase_dep libkworkspace)
- $(add_kdebase_dep liboxygenstyle)
- || ( <dev-qt/qtgui-4.8.5:4 ( >=dev-qt/qtgui-4.8.5:4 dev-qt/designer ) )
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libX11
- x11-libs/libxcb
- x11-libs/libXcomposite
- x11-libs/libXcursor
- x11-libs/libXdamage
- x11-libs/libXext
- x11-libs/libXfixes
- >=x11-libs/libXrandr-1.2.1
- x11-libs/libXrender
- x11-libs/libXxf86vm
- opengl? ( >=media-libs/mesa-7.10 )
- gles? (
- || ( ( >=media-libs/mesa-7.10[egl(+),gles] <media-libs/mesa-7.12[egl(+),gles] )
- >=media-libs/mesa-7.12[egl(+),gles2] )
- )
-"
-DEPEND="${COMMONDEPEND}
- x11-proto/compositeproto
- x11-proto/damageproto
- x11-proto/fixesproto
- x11-proto/randrproto
- x11-proto/renderproto
-"
-RDEPEND="${COMMONDEPEND}
- x11-apps/scripts
-"
-
-KMEXTRACTONLY="
- ksmserver/
- libs/kephal/
- libs/oxygen/
-"
-
-# you need one of these
-REQUIRED_USE="!opengl? ( gles ) !gles? ( opengl )"
-
-src_configure() {
- # FIXME Remove when activity API moved away from libkworkspace
- append-cppflags "-I${EPREFIX}/usr/include/kworkspace"
-
- mycmakeargs=(
- $(cmake-utils_use_with gles OpenGLES)
- $(cmake-utils_use gles KWIN_BUILD_WITH_OPENGLES)
- $(cmake-utils_use_with opengl OpenGL)
- -DWITH_X11_Xcomposite=ON
- )
-
- kde4-meta_src_configure
-}