aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-08-02 14:59:07 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-08-04 21:36:40 +0200
commit3c9f5ce04f52f6d73d750dfa10ef1daff3d8ba9b (patch)
tree50b430af373bd91afa5f326039ee964a29df9dd8 /kde-frameworks/kauth
parentkde-frameworks/threadweaver: 6.5.0 version bump (diff)
downloadkde-3c9f5ce04f52f6d73d750dfa10ef1daff3d8ba9b.tar.gz
kde-3c9f5ce04f52f6d73d750dfa10ef1daff3d8ba9b.tar.bz2
kde-3c9f5ce04f52f6d73d750dfa10ef1daff3d8ba9b.zip
kde-frameworks/kauth: 6.5.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kauth')
-rw-r--r--kde-frameworks/kauth/Manifest1
-rw-r--r--kde-frameworks/kauth/kauth-6.5.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/kde-frameworks/kauth/Manifest b/kde-frameworks/kauth/Manifest
new file mode 100644
index 0000000000..323121e4ba
--- /dev/null
+++ b/kde-frameworks/kauth/Manifest
@@ -0,0 +1 @@
+DIST kauth-6.5.0.tar.xz 2297228 BLAKE2B a031910ec0487d36a16fc6e8031224f5cf9b7bab259b4dbfb1380a72a91fc01139d19baa0a3fdb47e90fd8d19a9adf898cb1acca9c2876b9d51fa9d613ac3c20 SHA512 912efc795e5a9e8f91de99f8a39247052a25051935e721e26d5d376bbbff48b67cbeb93f5cabd5f4516ecace0765415463aee7f7f8397dee2c2a941528a7da3e
diff --git a/kde-frameworks/kauth/kauth-6.5.0.ebuild b/kde-frameworks/kauth/kauth-6.5.0.ebuild
new file mode 100644
index 0000000000..f8c77b5ddc
--- /dev/null
+++ b/kde-frameworks/kauth/kauth-6.5.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=6.6.2
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework to let applications perform actions as a privileged user"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="+policykit"
+
+RDEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[gui]
+ =kde-frameworks/kcoreaddons-${PVCUT}*:6
+ policykit? (
+ >=dev-qt/qtbase-${QTMIN}:6[dbus]
+ =kde-frameworks/kwindowsystem-${PVCUT}*:6[wayland]
+ >=sys-auth/polkit-qt-0.113.0[qt6(-)]
+ )
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-qt/qtbase-${QTMIN}:6[dbus] )
+"
+BDEPEND=">=dev-qt/qttools-${QTMIN}:6[linguist]"
+PDEPEND="policykit? ( kde-plasma/polkit-kde-agent:* )"
+
+CMAKE_SKIP_TESTS=(
+ # KAuthHelperTest test fails, bug 654842
+ KAuthHelperTest
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package policykit PolkitQt6-1)
+ )
+
+ ecm_src_configure
+}