aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-08-06 14:15:16 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-08-06 14:15:16 +0200
commit44c586c5b2fa707472589c16d45cdc8e1179d27e (patch)
treed02b3e29aa913e41d64ff581db62b1fffed04903 /kde-frameworks/kauth
parentkde-frameworks/kactivities: 5.85.0 version bump (diff)
downloadkde-44c586c5b2fa707472589c16d45cdc8e1179d27e.tar.gz
kde-44c586c5b2fa707472589c16d45cdc8e1179d27e.tar.bz2
kde-44c586c5b2fa707472589c16d45cdc8e1179d27e.zip
kde-frameworks/kauth: 5.85.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kauth')
-rw-r--r--kde-frameworks/kauth/Manifest1
-rw-r--r--kde-frameworks/kauth/kauth-5.85.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/kde-frameworks/kauth/Manifest b/kde-frameworks/kauth/Manifest
new file mode 100644
index 0000000000..a62ae4362b
--- /dev/null
+++ b/kde-frameworks/kauth/Manifest
@@ -0,0 +1 @@
+DIST kauth-5.85.0.tar.xz 88580 BLAKE2B bbb6d0d65c3ee0090ee8c7201938ca92cd59d9fbab84c6051b0937d9a6acd8fa3770f11a4e7cff32662c4d6d98296a58960700a87d9359124719be57f893ecaf SHA512 a775f1952ae112fc80a8119dd7060146dd427da6f73d9d3bb308c9683ffa263949e5f06615bc397806e951cf6156631a3d02505edc390c5982732199f17d812d
diff --git a/kde-frameworks/kauth/kauth-5.85.0.ebuild b/kde-frameworks/kauth/kauth-5.85.0.ebuild
new file mode 100644
index 0000000000..b87b08b797
--- /dev/null
+++ b/kde-frameworks/kauth/kauth-5.85.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework to let applications perform actions as a privileged user"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="nls +policykit"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ policykit? ( >=sys-auth/polkit-qt-0.113.0 )
+"
+RDEPEND="${DEPEND}"
+PDEPEND="policykit? ( kde-plasma/polkit-kde-agent )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_PythonModuleGeneration=ON # bug 746866
+ $(cmake_use_find_package policykit PolkitQt5-1)
+ )
+
+ ecm_src_configure
+}
+
+src_test() {
+ # KAuthHelperTest test fails, bug 654842
+ local myctestargs=(
+ -E "(KAuthHelperTest)"
+ )
+
+ ecm_src_test
+}