aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Huettel (dilfridge) <mail@akhuettel.de>2012-09-19 21:10:20 +0200
committerAndreas K. Huettel (dilfridge) <mail@akhuettel.de>2012-09-19 21:10:20 +0200
commit0ce4be372523c272746197aa1571298dbe3ff91e (patch)
tree47e88fd896051616b2f275464f16c82c124ed4cf /media-gfx
parent[kde-base/libkipi] Allow building libkipi master with kde-4.9 (diff)
downloadkde-0ce4be372523c272746197aa1571298dbe3ff91e.tar.gz
kde-0ce4be372523c272746197aa1571298dbe3ff91e.tar.bz2
kde-0ce4be372523c272746197aa1571298dbe3ff91e.zip
[media-gfx/digikam] Version bump to 3.0.0beta1
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/digikam/Manifest1
-rw-r--r--media-gfx/digikam/digikam-3.0.0_beta1.ebuild154
-rw-r--r--media-gfx/digikam/files/digikam-2.5.0-boost148.patch74
-rw-r--r--media-gfx/digikam/files/digikam-2.5.0-libkipi.patch75
-rw-r--r--media-gfx/digikam/metadata.xml15
5 files changed, 319 insertions, 0 deletions
diff --git a/media-gfx/digikam/Manifest b/media-gfx/digikam/Manifest
new file mode 100644
index 0000000000..23805cc668
--- /dev/null
+++ b/media-gfx/digikam/Manifest
@@ -0,0 +1 @@
+DIST digikam-3.0.0-beta1a.tar.bz2 57953932 SHA256 a1d5097eac1c867923e546eb0a42accf2a942422d48ee95272e1bcd26201ce34 SHA512 d3b9ffa17ae617dc5cd680fded6a722896ccfbf69501dd18ab780177f5fa8cf51272b06bd93285be55e8972d759ea027e800a23c110bd876e193c5a4b2fda4e3 WHIRLPOOL 803d38666180abec6fcd9242697daefbdff498085e164ef61ff574147d990cf3e4ae5086df613cf1b827351747e0c7f93161e63e754db130777aeb869bd951c1
diff --git a/media-gfx/digikam/digikam-3.0.0_beta1.ebuild b/media-gfx/digikam/digikam-3.0.0_beta1.ebuild
new file mode 100644
index 0000000000..093580102b
--- /dev/null
+++ b/media-gfx/digikam/digikam-3.0.0_beta1.ebuild
@@ -0,0 +1,154 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/digikam/digikam-2.9.0.ebuild,v 1.2 2012/09/04 14:56:27 creffett Exp $
+
+EAPI=4
+
+KDE_LINGUAS="af ar az be bg bn br bs ca cs csb cy da de el en_GB eo es et eu fa fi fo fr fy ga gl ha he hi hr hsb
+hu id is it ja ka kk km ko ku lb lo lt lv mi mk mn ms mt nb nds ne nl nn nso oc pa pl pt pt_BR ro ru
+rw se sk sl sq sr sr@Latn ss sv ta te tg th tr tt uk uz uz@cyrillic ven vi wa xh zh_CN zh_HK zh_TW zu"
+
+KDE_HANDBOOK="optional"
+CMAKE_MIN_VERSION="2.8"
+KDE_MINIMAL="4.9"
+
+KDE_DOC_DIRS="doc-digikam doc-showfoto"
+
+inherit kde4-base
+
+MY_PV=${PV/_/-}a
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Digital photo management application for KDE"
+HOMEPAGE="http://www.digikam.org/"
+SRC_URI="mirror://kde/unstable/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2
+ handbook? ( FDL-1.2 )"
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="addressbook debug doc gphoto2 mysql semantic-desktop themedesigner +thumbnails video"
+
+#Keep libf2c blocker until bug 433782 is resolved
+CDEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop=')
+ $(add_kdebase_dep kdebase-kioslaves)
+ $(add_kdebase_dep libkdcraw)
+ $(add_kdebase_dep libkexiv2)
+ $(add_kdebase_dep libkipi '' '4.9.80')
+ $(add_kdebase_dep marble plasma)
+ $(add_kdebase_dep solid)
+ media-libs/jasper
+ media-libs/lcms:0
+ media-libs/lensfun
+ media-libs/libkface
+ media-libs/libkgeomap
+ media-libs/liblqr
+ >=media-libs/libpgf-6.12.27
+ media-libs/libpng
+ media-libs/tiff
+ sci-libs/clapack
+ virtual/jpeg
+ x11-libs/qt-gui:4[qt3support]
+ || ( x11-libs/qt-sql:4[mysql] x11-libs/qt-sql:4[sqlite] )
+ addressbook? ( $(add_kdebase_dep kdepimlibs) )
+ gphoto2? ( media-libs/libgphoto2 )
+ mysql? ( virtual/mysql )
+"
+RDEPEND="${CDEPEND}
+ $(add_kdebase_dep kreadconfig)
+ media-plugins/kipi-plugins
+ video? (
+ || (
+ $(add_kdebase_dep mplayerthumbs)
+ $(add_kdebase_dep ffmpegthumbs)
+ )
+ )
+"
+DEPEND="${CDEPEND}
+ dev-libs/boost
+ sys-devel/gettext
+ doc? ( app-doc/doxygen )
+"
+
+S="${WORKDIR}/${MY_P}/core"
+
+RESTRICT=test
+# bug 366505
+
+src_prepare() {
+ # just to make absolutely sure
+ rm -rf "${WORKDIR}/${MY_P}/extra" || die
+
+ # prepare the handbook
+ mkdir doc-digikam doc-showfoto || die
+ echo "add_subdirectory( en )" > doc-digikam/CMakeLists.txt || die
+ mv "${WORKDIR}/${MY_P}/doc/${PN}/digikam" doc-digikam/en || die
+ echo "add_subdirectory( en )" > doc-showfoto/CMakeLists.txt || die
+ mv "${WORKDIR}/${MY_P}/doc/${PN}/showfoto" doc-showfoto/en || die
+ sed -i -e 's:../digikam/:../../doc-digikam/en/:g' doc-showfoto/en/index.docbook || die
+
+ # prepare the translations
+ mv "${WORKDIR}/${MY_P}/po" po || die
+ find po -name "*.po" -and -not -name "digikam.po" -exec rm {} +
+
+ echo "find_package(Msgfmt REQUIRED)" >> CMakeLists.txt || die
+ echo "find_package(Gettext REQUIRED)" >> CMakeLists.txt || die
+ echo "add_subdirectory( po )" >> CMakeLists.txt || die
+
+ kde4-base_src_prepare
+
+ if use handbook; then
+ echo "add_subdirectory( doc-digikam )" >> CMakeLists.txt
+ echo "add_subdirectory( doc-showfoto )" >> CMakeLists.txt
+ fi
+}
+
+src_configure() {
+ local backend
+
+ use semantic-desktop && backend="Nepomuk" || backend="None"
+ # LQR = only allows to choose between bundled/external
+ local mycmakeargs=(
+ -DFORCED_UNBUNDLE=ON
+ -DWITH_LQR=ON
+ -DWITH_LENSFUN=ON
+ -DGWENVIEW_SEMANTICINFO_BACKEND=${backend}
+ $(cmake-utils_use_with addressbook KdepimLibs)
+ -DWITH_MarbleWidget=ON
+ $(cmake-utils_use_enable gphoto2 GPHOTO2)
+ $(cmake-utils_use_with gphoto2)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ $(cmake-utils_use_enable themedesigner)
+ $(cmake-utils_use_enable thumbnails THUMBS_DB)
+ $(cmake-utils_use_enable mysql INTERNALMYSQL)
+ $(cmake-utils_use_enable debug DEBUG_MESSAGES)
+ )
+
+ kde4-base_src_configure
+}
+
+src_compile() {
+ local mytargets="all"
+ use doc && mytargets+=" doc"
+
+ kde4-base_src_compile ${mytargets}
+}
+
+src_install() {
+ kde4-base_src_install
+
+ if use doc; then
+ # install the api documentation
+ insinto /usr/share/doc/${PF}/
+ doins -r ${CMAKE_BUILD_DIR}/api/html
+ fi
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if use doc; then
+ elog "The digikam api documentation has been installed at /usr/share/doc/${PF}/html"
+ fi
+}
diff --git a/media-gfx/digikam/files/digikam-2.5.0-boost148.patch b/media-gfx/digikam/files/digikam-2.5.0-boost148.patch
new file mode 100644
index 0000000000..81198397ab
--- /dev/null
+++ b/media-gfx/digikam/files/digikam-2.5.0-boost148.patch
@@ -0,0 +1,74 @@
+commit d18ea6da2d3e2359f4113e83c3fd40c18a29ddab
+Author: Gilles Caulier <caulier.gilles@gmail.com>
+Date: Fri Jan 6 11:23:48 2012 +0100
+
+ Apply patch #67483 from Jeremiah Willcock to compile fine digiKam boost graph interface with libboost 1.48
+ BUGS: 287772
+ CCBUGS: 267777
+
+diff --git a/libs/database/imagehistory/imagehistorygraph_boost.h b/libs/database/imagehistory/imagehistorygraph_boost.h
+index 4017c4f..76c764a 100644
+--- a/libs/database/imagehistory/imagehistorygraph_boost.h
++++ b/libs/database/imagehistory/imagehistorygraph_boost.h
+@@ -1198,7 +1198,7 @@ protected:
+ {
+ boost::dag_shortest_paths(graph, v,
+ // we provide a constant weight of 1
+- weight_map(boost::ref_property_map<edge_t,int>(weight)).
++ weight_map(boost::ref_property_map<typename boost::graph_traits<GraphType>::edge_descriptor,int>(weight)).
+ // Store distance and predecessors in QMaps, wrapped to serve as property maps
+ distance_map(VertexIntMapAdaptor(distances)).
+ predecessor_map(VertexVertexMapAdaptor(predecessors))
+@@ -1218,7 +1218,7 @@ protected:
+ {
+ boost::dag_shortest_paths(graph, v,
+ // we provide a constant weight of 1
+- weight_map(boost::ref_property_map<edge_t,int>(weight)).
++ weight_map(boost::ref_property_map<typename boost::graph_traits<GraphType>::edge_descriptor,int>(weight)).
+ // Invert the default compare method: With greater, we get the longest path
+ distance_compare(std::greater<int>()).
+ // will be returned if a node is unreachable
+@@ -1384,14 +1384,15 @@ protected:
+ template <class GraphType, typename VertexLessThan>
+ class lessThanMapEdgeToTarget
+ {
++ typedef typename boost::graph_traits<GraphType>::edge_descriptor edge_descriptor;
+ public:
+ lessThanMapEdgeToTarget(const GraphType& g, VertexLessThan vertexLessThan)
+ : g(g), vertexLessThan(vertexLessThan) {}
+ const GraphType& g;
+ VertexLessThan vertexLessThan;
+- bool operator()(const Edge& a, const Edge& b)
++ bool operator()(const edge_descriptor& a, const edge_descriptor& b)
+ {
+- return vertexLessThan(boost::target(a.toEdge(), g), boost::target(b.toEdge(), g));
++ return vertexLessThan(boost::target(a, g), boost::target(b, g));
+ }
+ };
+
+@@ -1402,20 +1403,21 @@ protected:
+ {
+ typedef std::pair<Vertex, QList<Edge> > VertexInfo;
+
+- QList<Edge> outEdges;
++ typedef typename boost::graph_traits<IncidenceGraph>::edge_descriptor edge_descriptor;
++ QList<edge_descriptor> outEdges;
+ std::vector<VertexInfo> stack;
+
+ boost::put(color, u, boost::gray_color);
+ vis.discover_vertex(u, g);
+
+- outEdges = toEdgeList(boost::out_edges(u, g));
++ outEdges = toList<edge_descriptor>(boost::out_edges(u, g));
+ // Sort edges. The lessThan we have takes vertices, so we use a lessThan which
+ // maps the given edges to their targets, and calls our vertex lessThan.
+ qSort(outEdges.begin(), outEdges.end(), lessThanMapEdgeToTarget<IncidenceGraph, LessThan>(g, lessThan));
+
+- foreach(const Edge& e, outEdges)
++ foreach(const edge_descriptor& e, outEdges)
+ {
+- Vertex v = boost::target(e.toEdge(), g);
++ Vertex v = boost::target(e, g);
+ vis.examine_edge(e, g);
+ boost::default_color_type v_color = boost::get(color, v);
+ if (v_color == boost::white_color)
diff --git a/media-gfx/digikam/files/digikam-2.5.0-libkipi.patch b/media-gfx/digikam/files/digikam-2.5.0-libkipi.patch
new file mode 100644
index 0000000000..fbbac97a94
--- /dev/null
+++ b/media-gfx/digikam/files/digikam-2.5.0-libkipi.patch
@@ -0,0 +1,75 @@
+From 25cc9c9876a5233bd630105d0110319892d4e18c Mon Sep 17 00:00:00 2001
+From: Gilles Caulier <caulier.gilles@gmail.com>
+Date: Tue, 3 Jan 2012 15:16:37 +0100
+Subject: [PATCH] enable checkall and clearall buttons only with libkipi version 1.4.0
+ BUGS: 290496
+
+---
+ utilities/setup/setupplugins.cpp | 13 +++++++++++--
+ utilities/setup/setupplugins.h | 4 ++--
+ 2 files changed, 13 insertions(+), 4 deletions(-)
+
+diff --git a/utilities/setup/setupplugins.cpp b/utilities/setup/setupplugins.cpp
+index 0f4030a..b8efb35 100644
+--- a/utilities/setup/setupplugins.cpp
++++ b/utilities/setup/setupplugins.cpp
+@@ -6,8 +6,8 @@
+ * Date : 2004-01-02
+ * Description : setup Kipi plugins tab.
+ *
+- * Copyright (C) 2004-2011 by Gilles Caulier <caulier dot gilles at gmail dot com>
+- * Copyright (C) 2011 by Andi Clemens <andi dot clemens at googlemail dot com>
++ * Copyright (C) 2004-2012 by Gilles Caulier <caulier dot gilles at gmail dot com>
++ * Copyright (C) 2011-2012 by Andi Clemens <andi dot clemens at googlemail dot com>
+ *
+ * This program is free software; you can redistribute it
+ * and/or modify it under the terms of the GNU General
+@@ -100,6 +100,11 @@ SetupPlugins::SetupPlugins(QWidget* parent)
+
+ panel->setLayout(mainLayout);
+
++#if KIPI_VERSION < 0x010400
++ d->checkAllBtn->setVisible(false);
++ d->clearBtn->setVisible(false);
++#endif
++
+ initPlugins();
+
+ // --------------------------------------------------------
+@@ -158,14 +163,18 @@ void SetupPlugins::applyPlugins()
+ void SetupPlugins::slotCheckAll()
+ {
+ QApplication::setOverrideCursor(Qt::WaitCursor);
++#if KIPI_VERSION >= 0x010400
+ d->kipiConfig->slotCheckAll();
++#endif
+ QApplication::restoreOverrideCursor();
+ }
+
+ void SetupPlugins::slotClear()
+ {
+ QApplication::setOverrideCursor(Qt::WaitCursor);
++#if KIPI_VERSION >= 0x010400
+ d->kipiConfig->slotClear();
++#endif
+ QApplication::restoreOverrideCursor();
+ }
+
+diff --git a/utilities/setup/setupplugins.h b/utilities/setup/setupplugins.h
+index 271a569..114e0fa 100644
+--- a/utilities/setup/setupplugins.h
++++ b/utilities/setup/setupplugins.h
+@@ -6,8 +6,8 @@
+ * Date : 2004-01-02
+ * Description : setup Kipi plugins tab.
+ *
+- * Copyright (C) 2004-2011 by Gilles Caulier <caulier dot gilles at gmail dot com>
+- * Copyright (C) 2011 by Andi Clemens <andi dot clemens at googlemail dot com>
++ * Copyright (C) 2004-2012 by Gilles Caulier <caulier dot gilles at gmail dot com>
++ * Copyright (C) 2011-2012 by Andi Clemens <andi dot clemens at googlemail dot com>
+ *
+ * This program is free software; you can redistribute it
+ * and/or modify it under the terms of the GNU General
+--
+1.7.3.4
+
diff --git a/media-gfx/digikam/metadata.xml b/media-gfx/digikam/metadata.xml
new file mode 100644
index 0000000000..6764ab604d
--- /dev/null
+++ b/media-gfx/digikam/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+<maintainer><email>dilfridge@gentoo.org</email></maintainer>
+<use>
+ <flag name="addressbook">Add support for kdepim</flag>
+ <flag name="themedesigner">Build the digikam theme designer</flag>
+ <flag name="thumbnails">Enable thumbnails database support</flag>
+ <flag name="video">Pull in mplayerthumbs to enable video thumbnails</flag>
+ <flag name="linguas_ha">Hausa translation</flag>
+ <flag name="linguas_mi">Maori translation</flag>
+ <flag name="linguas_ven">Venda translation</flag>
+</use>
+</pkgmetadata>