aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-11-11 19:38:00 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-11-11 19:38:00 +0100
commit37fa313c4fbb9bdce14f52ee552618e61c3851a8 (patch)
treee295cb0618dcd801711a1c511a4884343ec7e7da /media-gfx
parentmedia-gfx/kio-mobi-thumbnailer: Add 24.12 stable branch (diff)
downloadkde-37fa313c4fbb9bdce14f52ee552618e61c3851a8.tar.gz
kde-37fa313c4fbb9bdce14f52ee552618e61c3851a8.tar.bz2
kde-37fa313c4fbb9bdce14f52ee552618e61c3851a8.zip
media-gfx/kio-ps-thumbnailer: Add 24.12 stable branch
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/kio-ps-thumbnailer/kio-ps-thumbnailer-24.12.49.9999.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-gfx/kio-ps-thumbnailer/kio-ps-thumbnailer-24.12.49.9999.ebuild b/media-gfx/kio-ps-thumbnailer/kio-ps-thumbnailer-24.12.49.9999.ebuild
new file mode 100644
index 0000000000..29283dbef1
--- /dev/null
+++ b/media-gfx/kio-ps-thumbnailer/kio-ps-thumbnailer-24.12.49.9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_NAME="kdegraphics-thumbnailers"
+KFMIN=6.5.0
+QTMIN=6.7.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="KIO thumbnail generator for DVI, EPS, PDF and PS files"
+HOMEPAGE="https://apps.kde.org/kdegraphics_thumbnailers/"
+
+LICENSE="GPL-2+"
+SLOT="6"
+KEYWORDS=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[gui]
+ >=kde-frameworks/kio-${KFMIN}:6
+"
+RDEPEND="${DEPEND}
+ !<kde-apps/thumbnailers-24.05.2-r1:6
+ app-text/dvipsk
+ app-text/ghostscript-gpl
+"
+
+src_prepare() {
+ ecm_src_prepare
+ ecm_punt_kf_module Archive
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_blend=OFF
+ -DDISABLE_MOBIPOCKET=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_QMobipocket6=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_KExiv2Qt6=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_KDcrawQt6=ON
+ )
+
+ ecm_src_configure
+}