aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-10-03 23:28:19 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-10-03 23:29:40 +0200
commitf23491ccba930a8108572bda4f42c664b3636e16 (patch)
treea2d6ad3a4e5247776d17727b487d430642761841 /www-client
parentkde-plasma/plasma-sdk: Cleanup excess whitespace (diff)
downloadkde-f23491ccba930a8108572bda4f42c664b3636e16.tar.gz
kde-f23491ccba930a8108572bda4f42c664b3636e16.tar.bz2
kde-f23491ccba930a8108572bda4f42c664b3636e16.zip
www-client/falkon: New package
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'www-client')
-rw-r--r--www-client/falkon/Manifest1
-rw-r--r--www-client/falkon/falkon-9999.ebuild68
-rw-r--r--www-client/falkon/metadata.xml15
3 files changed, 84 insertions, 0 deletions
diff --git a/www-client/falkon/Manifest b/www-client/falkon/Manifest
new file mode 100644
index 0000000000..9c6e143adb
--- /dev/null
+++ b/www-client/falkon/Manifest
@@ -0,0 +1 @@
+DIST qupzilla-plugins-2016.05.26.tar.gz 430926 SHA256 00967e12d319da991711e12767b7c7fe017dea1a7f1ec06627c2be8b13ce8687 SHA512 3b04b41208dddd25fd58937986cf12f2b521cf78a64380b915d46735ada3f4776f914056c5511daa781c89867d0309af7cbf833eb71dfa4b14b6b9ba25d80315 WHIRLPOOL 08124559291c3ccc387a9f3195060952cb4bed5e17920c472e7650d223b910cc60ebecdf831b4620b95ca22ec918add25c8009752098cec7a29ad5dad303ee9f
diff --git a/www-client/falkon/falkon-9999.ebuild b/www-client/falkon/falkon-9999.ebuild
new file mode 100644
index 0000000000..cab43a30f1
--- /dev/null
+++ b/www-client/falkon/falkon-9999.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PLUGINS_HASH="80fea7df7765fdf9c9c64fdb667052b25f1c0a22"
+PLUGINS_VERSION="2016.05.26" # if there are no updates, we can use the older archive
+# QT_MINIMAL="5.9.2"
+inherit kde5
+
+DESCRIPTION="Cross-platform web browser using QtWebEngine"
+HOMEPAGE="https://www.qupzilla.com/"
+SRC_URI+=" https://github.com/QupZilla/qupzilla-plugins/archive/${PLUGINS_HASH}.tar.gz -> qupzilla-plugins-${PLUGINS_VERSION}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="dbus gnome-keyring kwallet libressl nonblockdialogs +X"
+
+RDEPEND="
+ $(add_qt_dep qtdeclarative 'widgets')
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork 'ssl')
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtsql 'sqlite')
+ $(add_qt_dep qtwebchannel)
+ $(add_qt_dep qtwebengine 'widgets')
+ $(add_qt_dep qtwidgets)
+ dbus? ( $(add_qt_dep qtdbus) )
+ gnome-keyring? ( gnome-base/gnome-keyring )
+ kwallet? ( $(add_frameworks_dep kwallet) )
+ libressl? ( dev-libs/libressl:= )
+ !libressl? ( dev-libs/openssl:0= )
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libxcb:=
+ )
+"
+DEPEND="${RDEPEND}
+ $(add_qt_dep linguist-tools)
+ $(add_qt_dep qtconcurrent)
+ gnome-keyring? ( virtual/pkgconfig )
+"
+
+DOCS=( AUTHORS BUILDING.md CHANGELOG FAQ README.md )
+
+src_unpack() {
+ kde5_src_unpack
+ [[ ${KDE_BUILD_TYPE} = live && -n ${A} ]] && default
+}
+
+src_prepare() {
+ kde5_src_prepare
+ # get extra plugins into qupzilla build tree
+ mv "${WORKDIR}"/qupzilla-plugins-${PLUGINS_HASH}/plugins/* "${S}"/src/plugins/ || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_DBUS=$(usex dbus)
+ -DBUILD_KEYRING=$(usex gnome-keyring)
+ $(cmake-utils_use_find_package kwallet KF5Wallet)
+ -DNONBLOCK_JS_DIALOGS=$(usex nonblockdialogs)
+ -DNOT_X11=$(usex !X)
+ -DDISABLE_UPDATES_CHECK=OFF
+ )
+ kde5_src_configure
+}
diff --git a/www-client/falkon/metadata.xml b/www-client/falkon/metadata.xml
new file mode 100644
index 0000000000..97e1a6dcfd
--- /dev/null
+++ b/www-client/falkon/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>qt@gentoo.org</email>
+ <name>Gentoo Qt Project</name>
+ </maintainer>
+ <use>
+ <flag name="kwallet">Enable encrypted storage of passwords with <pkg>kde-frameworks/kwallet</pkg></flag>
+ <flag name="nonblockdialogs">Enable fancy non-blocking JavaScript dialogs
+ shown inside the page, not blocking the application window. When closing
+ browser windows with open dialogs, this can crash the application.
+ </flag>
+ </use>
+</pkgmetadata>