aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/kbibtex/files/kbibtex-doctools-optional.patch40
-rw-r--r--app-text/kbibtex/kbibtex-9999.ebuild20
2 files changed, 52 insertions, 8 deletions
diff --git a/app-text/kbibtex/files/kbibtex-doctools-optional.patch b/app-text/kbibtex/files/kbibtex-doctools-optional.patch
new file mode 100644
index 0000000000..57527b02ae
--- /dev/null
+++ b/app-text/kbibtex/files/kbibtex-doctools-optional.patch
@@ -0,0 +1,40 @@
+commit d23557e8a5c4170c5d2a20cb17421e5f0b303f94
+Author: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Sun Mar 13 12:22:09 2016 +0100
+
+ Make KF5DocTools optional
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index eb33c9e..0525db1 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -61,7 +61,6 @@ find_package(
+ find_package(
+ KF5 ${KF5_MIN_VERSION}
+ REQUIRED
+- DocTools
+ I18n
+ XmlGui
+ KIO
+@@ -74,6 +73,8 @@ find_package(
+ Wallet
+ )
+
++find_package(KF5DocTools)
++
+ # Version number for the exported headers / libs
+ set(
+ VERSION_BRANCH "0.8"
+@@ -182,9 +183,9 @@ add_subdirectory(
+ add_subdirectory(
+ xslt
+ )
++if(KF5DocTools_FOUND)
++ add_subdirectory(doc)
++endif()
+-add_subdirectory(
+- doc
+-)
+ add_subdirectory(
+ mime
+ )
diff --git a/app-text/kbibtex/kbibtex-9999.ebuild b/app-text/kbibtex/kbibtex-9999.ebuild
index c17e823168..0df48bf47e 100644
--- a/app-text/kbibtex/kbibtex-9999.ebuild
+++ b/app-text/kbibtex/kbibtex-9999.ebuild
@@ -2,11 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
KDE_DOXYGEN="true"
KDE_GCC_MINIMAL="4.9"
-KDE_HANDBOOK="forceoptional"
+KDE_HANDBOOK="optional"
inherit kde5
DESCRIPTION="BibTeX editor to edit bibliographies used with LaTeX"
@@ -33,24 +33,26 @@ DEPEND="
$(add_frameworks_dep kparts)
$(add_frameworks_dep kservice)
$(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwallet)
$(add_frameworks_dep kwidgetsaddons)
$(add_frameworks_dep kxmlgui)
- app-text/poppler[qt5]
- dev-libs/icu:=
- dev-libs/libxml2
- dev-libs/libxslt
- dev-libs/qoauth:5
$(add_qt_dep qtdbus)
$(add_qt_dep qtgui)
$(add_qt_dep qtnetwork)
$(add_qt_dep qtwebkit)
$(add_qt_dep qtwidgets)
$(add_qt_dep qtxml)
+ app-text/poppler[qt5]
+ dev-libs/icu:=
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-libs/qoauth:5
virtual/tex-base
"
RDEPEND="${DEPEND}
- dev-tex/bibtex2html
!app-text/kbibtex:4
+ dev-tex/bibtex2html
+ x11-misc/shared-mime-info
"
S=${WORKDIR}/${P/_/-}
@@ -58,6 +60,8 @@ S=${WORKDIR}/${P/_/-}
PATCHES=(
"${FILESDIR}/${PN}-revert-removing-qtoauth.patch"
"${FILESDIR}/${PN}-part-revert-reenable-qtoauth.patch"
+
+ "${FILESDIR}/${PN}-doctools-optional.patch" # RR pending upstream
)
src_prepare() {