aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/baloo/baloo-4.13.90.ebuild')
-rw-r--r--kde-base/baloo/baloo-4.13.90.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/kde-base/baloo/baloo-4.13.90.ebuild b/kde-base/baloo/baloo-4.13.90.ebuild
new file mode 100644
index 0000000000..3902ee863e
--- /dev/null
+++ b/kde-base/baloo/baloo-4.13.90.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit kde4-base
+
+DESCRIPTION="Next generation of the Nepomuk project"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+alternatekcm debug minimal"
+
+DEPEND="
+ $(add_kdebase_dep kdepimlibs)
+ $(add_kdebase_dep kfilemetadata)
+ dev-libs/qjson
+ =dev-libs/xapian-1.2*[chert]
+ sys-apps/attr
+ !<kde-base/nepomuk-4.12.50
+"
+RDEPEND="
+ ${DEPEND}
+"
+PDEPEND="alternatekcm? ( kde-misc/baloo-kcmadv )"
+
+RESTRICT="test"
+
+src_prepare() {
+ kde4-base_src_prepare
+ use alternatekcm && epatch "${FILESDIR}/${PN}-4.13.0-nokcm.patch"
+}
+
+src_install() {
+ kde4-base_src_install
+
+ if use minimal ; then
+ rm "${D}"/usr/bin/baloo*
+ rm -r "${D}"/usr/share/dbus-1
+ rm -r "${D}"/usr/share/icons
+ rm -r "${D}"/usr/share/polkit-1
+ fi
+}