summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim A. Misbakh-Soloviov <mva@mva.name>2014-06-16 16:32:08 +0700
committerVadim A. Misbakh-Soloviov <mva@mva.name>2014-06-16 16:32:08 +0700
commit24a4068be3a0c6f3989b3997072ffd3b98257c7c (patch)
tree227b395173c02115db624977c01cdb720debe708
parent[games-indie -> games-arcade] (diff)
downloadlua-24a4068be3a0c6f3989b3997072ffd3b98257c7c.tar.gz
lua-24a4068be3a0c6f3989b3997072ffd3b98257c7c.tar.bz2
lua-24a4068be3a0c6f3989b3997072ffd3b98257c7c.zip
[dev-lang/luajit] Bump to 2.0.3
Signed-off-by: Vadim A. Misbakh-Soloviov <mva@mva.name>
-rw-r--r--dev-lang/luajit/Manifest1
-rw-r--r--dev-lang/luajit/luajit-2.0.3.ebuild140
2 files changed, 141 insertions, 0 deletions
diff --git a/dev-lang/luajit/Manifest b/dev-lang/luajit/Manifest
index b425ae6..e506193 100644
--- a/dev-lang/luajit/Manifest
+++ b/dev-lang/luajit/Manifest
@@ -1 +1,2 @@
DIST LuaJIT-2.0.2.tar.gz 843031 SHA256 c05202974a5890e777b181908ac237625b499aece026654d7cc33607e3f46c38 SHA512 c1afea13ec61a59f37d1f61fc50bcac47208d9d4f0a80689b74e901ad2b34294b6c89a0b4eef54b43f3d2db411660da61b191b0bbfba4ba2f97743a9ee4484e3 WHIRLPOOL cb6e8ee6c5ac2293ca5d5452cda34769d3229e2d4681c0ce3c164659c2d2d781f8474e243747b197c10b3abc116e4145df6f5293317f1db871865f38ecd2b6cd
+DIST LuaJIT-2.0.3.tar.gz 844927 SHA256 55be6cb2d101ed38acca32c5b1f99ae345904b365b642203194c585d27bebd79 SHA512 7b3e3de22ac3602299b5918b60801e45a3278e547a15c16fdae7359538d4ada27ba664935d5f97c7409f330c2f8efeaae9ea03415f5e9d5a9d81e022cd5d36e0 WHIRLPOOL 1ba759b85048cfd57ebc02cfce477e9ddb327e7d27acd78f93fb2debfbf010a96e7b127324ebf6b81b1f35132f5a0a3a56ffca64fe0e66cba80c28b1cb49b433
diff --git a/dev-lang/luajit/luajit-2.0.3.ebuild b/dev-lang/luajit/luajit-2.0.3.ebuild
new file mode 100644
index 0000000..30252a5
--- /dev/null
+++ b/dev-lang/luajit/luajit-2.0.3.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: This ebuild is from Lua overlay; Bumped by mva; $
+
+EAPI="5"
+
+inherit base multilib pax-utils versionator toolchain-funcs flag-o-matic check-reqs
+
+MY_PV="$(get_version_component_range 1-3)"
+MY_P="LuaJIT-${MY_PV}"
+if [[ $(get_version_component_range 4) != "" ]]; then
+ HOTFIX="v${PV}"
+ HOTFIX="${HOTFIX/_p/_hotfix}.patch"
+fi
+
+DESCRIPTION="Just-In-Time Compiler for the Lua programming language"
+HOMEPAGE="http://luajit.org/"
+SRC_URI="
+ http://luajit.org/download/${MY_P}.tar.gz
+ ${HOTFIX:+http://luajit.org/download/${HOTFIX}}
+"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug lua52compat +optimization"
+
+DEPEND=""
+PDEPEND="
+ virtual/lua[luajit]
+"
+
+S="${WORKDIR}/${MY_P}"
+
+HTML_DOCS=( "doc/" )
+
+check_req() {
+ if use optimization; then
+ CHECKREQS_MEMORY="200M"
+ ewarn "Optimized (amalgamated) build wants at least 200MB of RAM"
+ ewarn "If you have no such RAM - try to disable 'optimization' flag"
+ check-reqs_pkg_${1}
+ fi
+}
+
+pkg_pretend() {
+ check_req pretend
+}
+
+pkg_setup() {
+ check_req setup
+}
+
+src_prepare() {
+ if [[ -n ${HOTFIX} ]]; then
+ epatch "${DISTDIR}/${HOTFIX}"
+ fi
+
+ # fixing prefix and version
+ sed \
+ -e "s|/usr/local|/usr|" \
+ -e "s|/lib|/$(get_libdir)|" \
+ -i Makefile || die "failed to fix prefix in Makefile"
+
+ sed \
+ -e "s|/usr/local|/usr|" \
+ -e "s|lib/|$(get_libdir)/|" \
+ -i src/luaconf.h || die "failed to fix prefix in luaconf.h"
+
+ sed \
+ -e "s|/usr/local|/usr|" \
+ -e "s|lib/|$(get_libdir)/|" \
+ -i etc/luajit.pc || die "failed to fix prefix in pkg-config file"
+
+ use debug && (
+ sed -r \
+ -e 's/#(CCDEBUG= -g)/\1 -ggdb/' \
+ -i src/Makefile || die "Failed to enable debug"
+ )
+}
+
+src_compile() {
+ local opt;
+ use optimization && opt="amalg";
+
+ if gcc-fullversion 4 7 3 && gcc-specs-pie && has ccache ${FEATURES}; then
+ # It is three ways to avoid compilation breaking
+ # in case, when user use gcc-4.7.3+pie+ccache:
+ # a) append -fPIC to CFLAGS, to use it even for temporary
+ # build-time only static host/* bins and luajit binary itself.
+ # b) append -nopie to LDFLAGS
+ # (for same binaries and same reason)
+ # c) disable ccache (even in per-package basis).
+ # This will slow down amalgamated build, but is prefered and
+ # recommended by upstream method.
+ # So, since it is impossible to use method "c" directly from
+ # ebuild, I choose method "a"
+ # (since it is more secure on hardened systems, imho) +
+ # + ewarn user, that he really should disable ccache.
+
+# append-ldflags -nopie
+ append-cflags -fPIC
+
+ ewarn "As we detected, that you're using gcc-4.7.3+pie+ccache,"
+ ewarn "we need to either:"
+ ewarn " a) add -fPIC to CFLAGS, or"
+ ewarn " b) add -nopie to LDFLAGS, or"
+ ewarn " c) disable ccache (even on per-package basis)."
+ ewarn ""
+ ewarn "We suggest you to use variant 'c' and disable it via"
+ ewarn "/etc/portage/{,package.}env (read portage manual)"
+ ewarn ""
+ ewarn "But, since we can't do that from ebuild, we'll continue"
+ ewarn "with -fPIC (variant 'a') for now, since it gives more security"
+ ewarn "on hardened systems (in our opinion)."
+ ewarn ""
+ ewarn "But, anyway, we still *HIGHLY* recommend you"
+ ewarn "to disable ccache instead."
+ fi
+
+ emake \
+ Q= \
+ HOST_CC="$(tc-getBUILD_CC)" \
+ STATIC_CC="$(tc-getCC)" \
+ DYNAMIC_CC="$(tc-getCC) -fPIC" \
+ TARGET_LD="$(tc-getCC)" \
+ TARGET_AR="$(tc-getAR) rcus" \
+ TARGET_STRIP="true" \
+ XCFLAGS="$(usex lua52compat "-DLUAJIT_ENABLE_LUA52COMPAT" "")" \
+ "${opt}"
+}
+
+src_install() {
+ default
+ base_src_install_docs
+
+ host-is-pax && pax-mark m "${ED}usr/bin/${PN}-${MY_PV}"
+ dosym "${PN}-${MY_PV}" "/usr/bin/${PN}"
+ dobin "${FILESDIR}/luac.jit"
+}