aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2020-05-04 20:37:01 +0300
committerJory Pratt <anarchy@gentoo.org>2020-05-07 19:02:16 -0500
commit5b79aeba24ffaae7709624fef87d758ce13b4eec (patch)
tree7552d90f7964724510f2565f03bf11f85c432be4 /sys-libs
parentsys-libs/tevent: add missing sys/types.h header for pid_t (diff)
downloadmusl-5b79aeba24ffaae7709624fef87d758ce13b4eec.tar.gz
musl-5b79aeba24ffaae7709624fef87d758ce13b4eec.tar.bz2
musl-5b79aeba24ffaae7709624fef87d758ce13b4eec.zip
sys-libs/ldb: add missing include of fcntl.h
Fixes #305. Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> Signed-off-by: Jory Pratt <anarchy@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/ldb/files/ldb-2.0.8-include-fcntl.h-for-pid_t.patch10
-rw-r--r--sys-libs/ldb/ldb-2.0.8.ebuild1
2 files changed, 11 insertions, 0 deletions
diff --git a/sys-libs/ldb/files/ldb-2.0.8-include-fcntl.h-for-pid_t.patch b/sys-libs/ldb/files/ldb-2.0.8-include-fcntl.h-for-pid_t.patch
new file mode 100644
index 00000000..d1e0ed1e
--- /dev/null
+++ b/sys-libs/ldb/files/ldb-2.0.8-include-fcntl.h-for-pid_t.patch
@@ -0,0 +1,10 @@
+--- a/include/ldb.h
++++ b/include/ldb.h
+@@ -46,6 +46,7 @@
+ #define _LDB_H_ 1
+ /*! \endcond */
+
++#include <fcntl.h>
+ #include <stdbool.h>
+ #include <talloc.h>
+ #include <tevent.h>
diff --git a/sys-libs/ldb/ldb-2.0.8.ebuild b/sys-libs/ldb/ldb-2.0.8.ebuild
index dbd9db13..06ee8540 100644
--- a/sys-libs/ldb/ldb-2.0.8.ebuild
+++ b/sys-libs/ldb/ldb-2.0.8.ebuild
@@ -47,6 +47,7 @@ MULTILIB_WRAPPED_HEADERS=( /usr/include/pyldb.h )
PATCHES=(
"${FILESDIR}"/${PN}-1.5.2-optional_packages.patch
"${FILESDIR}"/${PN}-1.1.31-fix_PKGCONFIGDIR-when-python-disabled.patch
+ "${FILESDIR}"/${P}-include-fcntl.h-for-pid_t.patch
)
pkg_setup() {