aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <w.d.hubbs@gmail.com>2013-03-18 17:10:58 -0500
committerWilliam Hubbs <w.d.hubbs@gmail.com>2013-04-06 17:26:10 -0500
commit1e6cef540789ce8b781eb3037ff7058c1a07c07d (patch)
treece43b4782513deea473fc9aa3348c146307dda4f /net/Makefile
downloadnetifrc-1e6cef540789ce8b781eb3037ff7058c1a07c07d.tar.gz
netifrc-1e6cef540789ce8b781eb3037ff7058c1a07c07d.tar.bz2
netifrc-1e6cef540789ce8b781eb3037ff7058c1a07c07d.zip
initial commit ported from OpenRc
Diffstat (limited to 'net/Makefile')
-rw-r--r--net/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
new file mode 100644
index 0000000..a03c171
--- /dev/null
+++ b/net/Makefile
@@ -0,0 +1,24 @@
+DIR= ${LIBEXECDIR}/net
+SRCS= ifconfig.sh.in ${SRCS-${OS}}
+INC= dhclient.sh dhcpcd.sh ifconfig.sh macchanger.sh macnet.sh \
+ ssidnet.sh system.sh wpa_supplicant.sh ${INC-${OS}}
+
+MK= ../mk
+include ${MK}/os.mk
+
+SRCS-FreeBSD= iwconfig.sh.in
+INC-FreeBSD= iwconfig.sh
+
+SRCS-Linux= iwconfig.sh.in udhcpc.sh.in
+INC-Linux= adsl.sh apipa.sh arping.sh bonding.sh br2684ctl.sh bridge.sh \
+ ccwgroup.sh clip.sh ethtool.sh iproute2.sh ifplugd.sh ip6to4.sh \
+ ipppd.sh iwconfig.sh netplugd.sh pppd.sh pump.sh tuntap.sh udhcpc.sh \
+ vlan.sh macvlan.sh ip6rd.sh firewalld.sh
+
+SRCS-NetBSD= ifwatchd.sh.in
+INC-NetBSD= ifwatchd.sh
+
+%.sh.in: %.sh${SFX}
+ ${CP} $< $@
+
+include ${MK}/scripts.mk