aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-02-08 00:24:32 -0500
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-02-08 00:26:21 -0500
commitf75afcc457f08549e378dfabc205dec5fa98e1c5 (patch)
tree91e6f4f32c00e3766222d42da08d5059ad23f5a5 /Makefile.am
parentFix transient hostname error handling, and dynamically allocate it (diff)
downloadopenrc-settingsd-f75afcc457f08549e378dfabc205dec5fa98e1c5.tar.gz
openrc-settingsd-f75afcc457f08549e378dfabc205dec5fa98e1c5.tar.bz2
openrc-settingsd-f75afcc457f08549e378dfabc205dec5fa98e1c5.zip
Add DTD to hostname introspection xml file, and give it a better name
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 58a1dea..6b6cb78 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,7 @@
ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
EXTRA_DIST = \
- data/hostnamed.xml \
+ data/hostname1.xml \
$(NULL)
AM_CPPFLAGS = \
@@ -33,12 +33,12 @@ openrc_settingsd_SOURCES = \
src/main.c \
$(NULL)
-$(hostnamed_built_sources) : data/hostnamed.xml
+$(hostnamed_built_sources) : data/hostname1.xml
( $(GDBUS_CODEGEN) \
--interface-prefix org.freedesktop. \
--c-namespace OpenrcSettingsdHostnamed \
--generate-c-code hostnamed-generated \
- $(srcdir)/data/hostnamed.xml; \
+ $(srcdir)/data/hostname1.xml; \
mv hostnamed-generated.{c,h} $(top_srcdir)/src/ )
BUILT_SOURCES = $(hostnamed_built_sources)