aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gmail.com>2019-11-14 23:31:09 -0700
committerTim Harder <radhermit@gmail.com>2019-11-14 23:31:09 -0700
commit7117cb78aa32b8322b14be8fcacdadc69a348fcb (patch)
tree65c541201f44358b559fc0eac5fa7baef1670041 /pyproject.toml
parentProfileNode: packages: out log errors for malformed pkg atoms (diff)
downloadpkgcore-7117cb78aa32b8322b14be8fcacdadc69a348fcb.tar.gz
pkgcore-7117cb78aa32b8322b14be8fcacdadc69a348fcb.tar.bz2
pkgcore-7117cb78aa32b8322b14be8fcacdadc69a348fcb.zip
default to using pyproject.toml with dev dep versions
The release version will be swapped in via CI for releases/deploy tests.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 3554aa186..5b8ac3736 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,3 +1,6 @@
[build-system]
-requires = ["wheel", "setuptools", "snakeoil~=0.8.3"]
+requires = [
+ "wheel", "setuptools",
+ "https://github.com/pkgcore/snakeoil/archive/master.tar.gz#egg=snakeoil",
+]
build-backend = "setuptools.build_meta"