aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-12-25 19:53:54 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-12-25 19:53:54 +0200
commit38acafe261d9afca8d3c712994e0f52024dfd548 (patch)
treeaa82827bdcb7f2c7cef6870982387977b5edbfbb
parentSuppress the black reformat commit from git blame (diff)
downloadsnakeoil-38acafe261d9afca8d3c712994e0f52024dfd548.tar.gz
snakeoil-38acafe261d9afca8d3c712994e0f52024dfd548.tar.bz2
snakeoil-38acafe261d9afca8d3c712994e0f52024dfd548.zip
Makefile: add black format target
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index f49201a..b5cadc8 100644
--- a/Makefile
+++ b/Makefile
@@ -13,3 +13,7 @@ sdist wheel:
.PHONY: clean
clean:
$(RM) -r build/sphinx doc/api dist
+
+.PHONY: format
+format:
+ $(PYTHON) -m black .