aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2020-05-16 20:24:45 +0200
committerFabian Groffen <grobian@gentoo.org>2020-05-16 20:24:45 +0200
commitdcab7ec282cfb8827a95c59c51322271d14d91c4 (patch)
tree1b03f82f9e87e4643fdf43f139855e7e25bd7f1e /Makefile.am
parentqfile: print symlink targets in verbose mode (diff)
downloadportage-utils-dcab7ec282cfb8827a95c59c51322271d14d91c4.tar.gz
portage-utils-dcab7ec282cfb8827a95c59c51322271d14d91c4.tar.bz2
portage-utils-dcab7ec282cfb8827a95c59c51322271d14d91c4.zip
libq/hash: unify hash methods into single approach
remove duplicate hashing strategies, use private copies of md5 and sha1 hashes when ssl is not available, else rely on ssl to provide hashing capabilities Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 2 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index 3107bda9..ceded249 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -69,10 +69,12 @@ q_CPPFLAGS = \
-I$(top_srcdir)/libq \
-I$(top_builddir)/autotools/gnulib \
-I$(top_srcdir)/autotools/gnulib \
+ $(OPENMP_CFLAGS) \
$(NULL)
q_LDADD = \
$(top_builddir)/libq/libq.la \
$(top_builddir)/autotools/gnulib/libgnu.a \
+ $(OPENMP_CFLAGS) \
$(LIBSSL) \
$(LIBBL2) \
$(LIBZ) \
@@ -84,21 +86,12 @@ q_LDADD = \
if QMANIFEST_ENABLED
q_SOURCES += qmanifest.c
q_CPPFLAGS += \
- $(OPENMP_CFLAGS) \
$(GPGME_CFLAGS)
-q_LDADD += \
- $(OPENMP_CFLAGS)
dist_man_MANS += man/qmanifest.1
APPLETS += qmanifest
endif
if QTEGRITY_ENABLED
q_SOURCES += qtegrity.c
-if !QMANIFEST_ENABLED
-q_CPPFLAGS += \
- $(OPENMP_CFLAGS)
-q_LDADD += \
- $(OPENMP_CFLAGS)
-endif
dist_man_MANS += man/qtegrity.1
APPLETS += qtegrity
endif