summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-02-19 10:57:16 -0500
committerMike Gilbert <floppym@gentoo.org>2017-02-19 11:29:05 -0500
commit9df02db73e7d157bc79be30c57ad8295a2daa93d (patch)
tree58787cc4b0e9dc124465ab54de2c2edad8edca47
parentUpdate from Arfrever (diff)
downloadpython-gentoo-patches-2.7.13-0.tar.gz
python-gentoo-patches-2.7.13-0.tar.bz2
python-gentoo-patches-2.7.13-0.zip
Update 2.7 from Arfrever2.7.13-0
-rw-r--r--patches/01_all_static_library_location.patch4
-rw-r--r--patches/03_all_libdir.patch8
-rw-r--r--patches/04_all_non-zero_exit_status_on_failure.patch2
-rw-r--r--patches/05_all_loadable_sqlite_extensions.patch2
-rw-r--r--patches/06_all_regenerate_platform-specific_modules.patch12
-rw-r--r--patches/21_all_distutils_c++.patch2
-rw-r--r--patches/24_all_tests_environment.patch4
-rw-r--r--patches/25_all_expat-2.2.patch19
8 files changed, 17 insertions, 36 deletions
diff --git a/patches/01_all_static_library_location.patch b/patches/01_all_static_library_location.patch
index f394740..b375144 100644
--- a/patches/01_all_static_library_location.patch
+++ b/patches/01_all_static_library_location.patch
@@ -4,7 +4,7 @@ https://bugs.python.org/issue6103
--- Makefile.pre.in
+++ Makefile.pre.in
-@@ -1014,6 +1014,19 @@
+@@ -1002,6 +1002,19 @@
fi; \
else true; \
fi
@@ -24,7 +24,7 @@ https://bugs.python.org/issue6103
# Install the versioned manual page
altmaninstall:
-@@ -1211,18 +1224,6 @@
+@@ -1199,18 +1212,6 @@
else true; \
fi; \
done
diff --git a/patches/03_all_libdir.patch b/patches/03_all_libdir.patch
index de82e44..c8b5ce4 100644
--- a/patches/03_all_libdir.patch
+++ b/patches/03_all_libdir.patch
@@ -71,9 +71,9 @@
'data' : '{userbase}',
--- Lib/test/test_site.py
+++ Lib/test/test_site.py
-@@ -247,10 +247,10 @@
+@@ -236,10 +236,10 @@
elif os.sep == '/':
- # OS X non-framwework builds, Linux, FreeBSD, etc
+ # OS X, Linux, FreeBSD, etc
self.assertEqual(len(dirs), 2)
- wanted = os.path.join('xoxo', 'lib', 'python' + sys.version[:3],
+ wanted = os.path.join('xoxo', '@@GENTOO_LIBDIR@@', 'python' + sys.version[:3],
@@ -117,7 +117,7 @@
static void
reduce(char *dir)
-@@ -522,7 +522,7 @@
+@@ -520,7 +520,7 @@
}
else
strncpy(zip_path, PREFIX, MAXPATHLEN);
@@ -126,7 +126,7 @@
bufsz = strlen(zip_path); /* Replace "00" with version */
zip_path[bufsz - 6] = VERSION[0];
zip_path[bufsz - 5] = VERSION[2];
-@@ -532,7 +532,7 @@
+@@ -530,7 +530,7 @@
fprintf(stderr,
"Could not find platform dependent libraries <exec_prefix>\n");
strncpy(exec_prefix, EXEC_PREFIX, MAXPATHLEN);
diff --git a/patches/04_all_non-zero_exit_status_on_failure.patch b/patches/04_all_non-zero_exit_status_on_failure.patch
index e823ce0..a8ede2f 100644
--- a/patches/04_all_non-zero_exit_status_on_failure.patch
+++ b/patches/04_all_non-zero_exit_status_on_failure.patch
@@ -23,7 +23,7 @@ https://bugs.python.org/issue6731
failed = self.failed[:]
print
print "Failed to build these modules:"
-@@ -2261,6 +2266,7 @@
+@@ -2263,6 +2268,7 @@
'Tools/scripts/2to3',
'Lib/smtpd.py']
)
diff --git a/patches/05_all_loadable_sqlite_extensions.patch b/patches/05_all_loadable_sqlite_extensions.patch
index 0ca4c8c..00b16d4 100644
--- a/patches/05_all_loadable_sqlite_extensions.patch
+++ b/patches/05_all_loadable_sqlite_extensions.patch
@@ -3,7 +3,7 @@ https://bugs.python.org/issue10268
--- configure.ac
+++ configure.ac
-@@ -2441,6 +2441,15 @@
+@@ -2504,6 +2504,15 @@
TCLTK_LIBS="$with_tcltk_libs"
fi
diff --git a/patches/06_all_regenerate_platform-specific_modules.patch b/patches/06_all_regenerate_platform-specific_modules.patch
index 614b09c..fe709fb 100644
--- a/patches/06_all_regenerate_platform-specific_modules.patch
+++ b/patches/06_all_regenerate_platform-specific_modules.patch
@@ -37,16 +37,16 @@ https://bugs.python.org/issue12619
+python$EXE ../../Tools/scripts/h2py.py /usr/include/sys/stropts.h
--- Makefile.pre.in
+++ Makefile.pre.in
-@@ -430,7 +430,7 @@
+@@ -429,7 +429,7 @@
# Default target
- all: build_all
+ all: @DEF_MAKE_ALL_RULE@
-build_all: $(BUILDPYTHON) oldsharedmods sharedmods gdbhooks
+build_all: $(BUILDPYTHON) oldsharedmods sharedmods platformspecificmods gdbhooks
# Compile a binary with profile guided optimization.
profile-opt:
-@@ -548,6 +548,32 @@
+@@ -547,6 +547,32 @@
_TCLTK_INCLUDES='$(TCLTK_INCLUDES)' _TCLTK_LIBS='$(TCLTK_LIBS)' \
$(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
@@ -79,7 +79,7 @@ https://bugs.python.org/issue12619
# Build static library
# avoid long command lines, same as LIBRARY_OBJS
$(LIBRARY): $(LIBRARY_OBJS)
-@@ -1085,7 +1111,7 @@
+@@ -1073,7 +1099,7 @@
unittest unittest/test \
lib-old \
curses pydoc_data $(MACHDEPS)
@@ -88,7 +88,7 @@ https://bugs.python.org/issue12619
@for i in $(SCRIPTDIR) $(LIBDEST); \
do \
if test ! -d $(DESTDIR)$$i; then \
-@@ -1168,23 +1194,6 @@
+@@ -1156,23 +1182,6 @@
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/PatternGrammar.txt
@@ -112,7 +112,7 @@ https://bugs.python.org/issue12619
python-config: $(srcdir)/Misc/python-config.in
# Substitution happens here, as the completely-expanded BINDIR
# is not available in configure
-@@ -1481,7 +1490,7 @@
+@@ -1473,7 +1482,7 @@
Python/thread.o: @THREADHEADERS@
# Declare targets that aren't real files
diff --git a/patches/21_all_distutils_c++.patch b/patches/21_all_distutils_c++.patch
index 873f745..0894c46 100644
--- a/patches/21_all_distutils_c++.patch
+++ b/patches/21_all_distutils_c++.patch
@@ -262,7 +262,7 @@ https://bugs.python.org/issue1222585
linker = _osx_support.compiler_fixup(linker, ld_args)
--- Makefile.pre.in
+++ Makefile.pre.in
-@@ -544,7 +544,7 @@
+@@ -543,7 +543,7 @@
*\ -s*|s*) quiet="-q";; \
*) quiet="";; \
esac; \
diff --git a/patches/24_all_tests_environment.patch b/patches/24_all_tests_environment.patch
index 53c50f8..f03859c 100644
--- a/patches/24_all_tests_environment.patch
+++ b/patches/24_all_tests_environment.patch
@@ -2,7 +2,7 @@ https://bugs.python.org/issue1674555
--- Lib/site.py
+++ Lib/site.py
-@@ -527,8 +527,12 @@
+@@ -518,8 +518,12 @@
known_paths = removeduppaths()
if ENABLE_USER_SITE is None:
ENABLE_USER_SITE = check_enableusersite()
@@ -180,7 +180,7 @@ https://bugs.python.org/issue1674555
--- Makefile.pre.in
+++ Makefile.pre.in
-@@ -893,7 +893,7 @@
+@@ -881,7 +881,7 @@
TESTOPTS= -l $(EXTRATESTOPTS)
TESTPROG= $(srcdir)/Lib/test/regrtest.py
diff --git a/patches/25_all_expat-2.2.patch b/patches/25_all_expat-2.2.patch
deleted file mode 100644
index 1ff9cf4..0000000
--- a/patches/25_all_expat-2.2.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-https://bugs.python.org/issue27369
-https://hg.python.org/cpython/rev/2d6e6600c210
-
---- Lib/test/test_pyexpat.py
-+++ Lib/test/test_pyexpat.py
-@@ -610,11 +610,9 @@
- def test2(self):
- xml = "<?xml version\xc2\x85='1.0'?>\r\n"
- parser = expat.ParserCreate()
-- try:
-+ err_pattern = r'XML declaration not well-formed: line 1, column \d+'
-+ with self.assertRaisesRegexp(expat.ExpatError, err_pattern):
- parser.Parse(xml, True)
-- self.fail()
-- except expat.ExpatError as e:
-- self.assertEqual(str(e), 'XML declaration not well-formed: line 1, column 14')
-
- class ForeignDTDTests(unittest.TestCase):
- """