aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2015-01-29 01:26:46 +0100
committerDavide Pesavento <pesa@gentoo.org>2015-01-29 01:26:46 +0100
commit9ed67473bad35fca5c6dac9f672af70c1a04e055 (patch)
treed67b2d6c23c2ea652fda8fa5876ddc1584997953 /app-crypt
parent[dev-libs/qoauth] Sync with tree, EAPI 5 (diff)
downloadqt-9ed67473bad35fca5c6dac9f672af70c1a04e055.tar.gz
qt-9ed67473bad35fca5c6dac9f672af70c1a04e055.tar.bz2
qt-9ed67473bad35fca5c6dac9f672af70c1a04e055.zip
[app-crypt/qca] Minor cleanup.
Package-Manager: portage-2.2.15
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/qca/qca-9999.ebuild27
1 files changed, 9 insertions, 18 deletions
diff --git a/app-crypt/qca/qca-9999.ebuild b/app-crypt/qca/qca-9999.ebuild
index 2d7f1d46..54ed4b8d 100644
--- a/app-crypt/qca/qca-9999.ebuild
+++ b/app-crypt/qca/qca-9999.ebuild
@@ -4,8 +4,9 @@
EAPI=5
-# for mulibuild support, until merged to master
+# for multibuild support, until merged to master
EGIT_BRANCH="qt5"
+
inherit multilib cmake-utils multibuild git-r3
DESCRIPTION="Qt Cryptographic Architecture (QCA)"
@@ -59,14 +60,7 @@ qca_plugin_use() {
}
pkg_setup() {
- MULTIBUILD_VARIANTS=()
- if use qt4; then
- MULTIBUILD_VARIANTS+=(qt4)
- fi
-
- if use qt5; then
- MULTIBUILD_VARIANTS+=(qt5)
- fi
+ MULTIBUILD_VARIANTS=( $(usev qt4) $(usev qt5) )
}
src_configure() {
@@ -109,24 +103,21 @@ src_compile() {
multibuild_foreach_variant cmake-utils_src_compile
}
+src_test() {
+ multibuild_foreach_variant cmake-utils_src_test
+}
+
src_install() {
multibuild_foreach_variant cmake-utils_src_install
if use doc; then
pushd "${BUILD_DIR}" >/dev/null
doxygen Doxyfile.in || die
- dohtml apidocs/html/*
+ dodoc -r apidocs/html
popd >/dev/null
fi
if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r "${S}"/examples
+ dodoc -r "${S}"/examples
fi
-
- cmake-utils_src_install
-}
-
-src_test() {
- multibuild_foreach_variant cmake-utils_src_test
}