aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-07-04 13:42:07 +0200
committerJohannes Huber <johu@gentoo.org>2012-07-04 13:42:07 +0200
commitbf221c0261b3c86a2598078551e8117f95f94fae (patch)
tree31dec336d4358161731ea9bafe7f4e3ad52600b2 /app-editors
parentDelete trailing whitespace from several metadata.xml files. (diff)
downloadqt-bf221c0261b3c86a2598078551e8117f95f94fae.tar.gz
qt-bf221c0261b3c86a2598078551e8117f95f94fae.tar.bz2
qt-bf221c0261b3c86a2598078551e8117f95f94fae.zip
[app-editors/vim-qt] Initial import. Ebuild by Elijah El Lazkani <ThyArmageddon+GentooOverlay@Gmail.com>.
(Portage version: 2.2.0_alpha115/git/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vim-qt/metadata.xml10
-rw-r--r--app-editors/vim-qt/vim-qt-9999.ebuild59
2 files changed, 69 insertions, 0 deletions
diff --git a/app-editors/vim-qt/metadata.xml b/app-editors/vim-qt/metadata.xml
new file mode 100644
index 00000000..be850cb2
--- /dev/null
+++ b/app-editors/vim-qt/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <maintainer>
+ <email>ThyArmageddon+Gentoo@Gmail.com</email>
+ <name>Elijah El Lazkani</name>
+ </maintainer>
+ <longdescription lang="en">The well known vim editor with a Qt based front-end interface</longdescription>
+</pkgmetadata>
diff --git a/app-editors/vim-qt/vim-qt-9999.ebuild b/app-editors/vim-qt/vim-qt-9999.ebuild
new file mode 100644
index 00000000..8026f03c
--- /dev/null
+++ b/app-editors/vim-qt/vim-qt-9999.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit eutils toolchain-funcs flag-o-matic git-2
+
+DESCRIPTION="Qt GUI version of the Vim text editor"
+HOMEPAGE="https://bitbucket.org/equalsraf/vim-qt/overview"
+EGIT_REPO_URI="git://gitorious.org/${PN}/${PN}.git
+ https://gitorious.org/${PN}/${PN}.git"
+
+LICENSE="vim"
+SLOT="0"
+KEYWORDS=""
+IUSE="acl cscope debug gpm nls perl python ruby"
+
+COMMON_DEPEND="
+ app-admin/eselect-vi
+ =app-editors/vim-core-7.3.487
+ sys-libs/ncurses
+ >=x11-libs/qt-core-4.7.0:4
+ >=x11-libs/qt-gui-4.7.0:4
+ acl? ( kernel_linux? ( sys-apps/acl ) )
+ cscope? ( dev-util/cscope )
+ gpm? ( sys-libs/gpm )
+ nls? ( virtual/libintl )
+ perl? ( dev-lang/perl )
+ ruby? ( dev-lang/ruby:1.8 )"
+DEPEND="${COMMON_DEPEND}
+ sys-devel/autoconf"
+RDEPEND="${COMMON_DEPEND}"
+
+src_configure() {
+ use debug && append-flags "-DDEBUG"
+
+ local myconf="--with-features=huge
+ --enable-multibyte"
+ myconf+=" $(use_enable acl)"
+ myconf+=" $(use_enable gpm)"
+ myconf+=" $(use_enable nls)"
+ myconf+=" $(use_enable perl perlinterp)"
+ myconf+=" $(use_enable python pythoninterp)"
+ myconf+=" $(use_enable ruby rubyinterp)"
+ myconf+=" --enable-gui=qt --with-vim-name=qvim --with-x"
+
+ if ! use cscope ; then
+ sed -i -e '/# define FEAT_CSCOPE/d' src/feature.h || \
+ die "couldn't disable cscope"
+ fi
+ econf ${myconf}
+}
+
+src_install() {
+ dobin src/qvim
+ doicon -s 64 src/qt/icons/vim-qt.png
+ make_desktop_entry qvim Vim-qt vim-qt "QT;TextEditor;Development;"
+}