aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2018-01-26 11:32:44 +0200
committerJimi Huotari <chiitoo@gentoo.org>2018-01-26 11:32:44 +0200
commit1aab573c609dfe41d406542c1e23df26873b5e08 (patch)
tree3d20360feed97c4df57407b437d72d553a45e46f /dev-qt/assistant
parentqt5-build.eclass: relax qconfig-qtcore.pri insertion to all 5.9 and later (diff)
downloadqt-1aab573c609dfe41d406542c1e23df26873b5e08.tar.gz
qt-1aab573c609dfe41d406542c1e23df26873b5e08.tar.bz2
qt-1aab573c609dfe41d406542c1e23df26873b5e08.zip
dev-qt: add 5.11.9999
Package-Manager: Portage-2.3.20, Repoman-2.3.6
Diffstat (limited to 'dev-qt/assistant')
-rw-r--r--dev-qt/assistant/assistant-5.11.9999.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-qt/assistant/assistant-5.11.9999.ebuild b/dev-qt/assistant/assistant-5.11.9999.ebuild
new file mode 100644
index 00000000..0fe2bc14
--- /dev/null
+++ b/dev-qt/assistant/assistant-5.11.9999.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+QT5_MODULE="qttools"
+inherit desktop gnome2-utils qt5-build
+
+DESCRIPTION="Tool for viewing on-line documentation in Qt help file format"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86"
+fi
+
+IUSE="webkit"
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtgui-${PV}
+ ~dev-qt/qthelp-${PV}
+ ~dev-qt/qtnetwork-${PV}
+ ~dev-qt/qtprintsupport-${PV}
+ ~dev-qt/qtsql-${PV}[sqlite]
+ ~dev-qt/qtwidgets-${PV}
+ webkit? ( >=dev-qt/qtwebkit-5.9.1:5 )
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/assistant/assistant
+)
+
+src_prepare() {
+ qt_use_disable_mod webkit webkitwidgets \
+ src/assistant/assistant/assistant.pro
+
+ qt5-build_src_prepare
+}
+
+src_install() {
+ qt5-build_src_install
+
+ doicon -s 32 src/assistant/assistant/images/assistant.png
+ newicon -s 128 src/assistant/assistant/images/assistant-128.png assistant.png
+ make_desktop_entry "${QT5_BINDIR}"/assistant 'Qt 5 Assistant' assistant 'Qt;Development;Documentation'
+}
+
+pkg_postinst() {
+ qt5-build_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ qt5-build_pkg_postrm
+ gnome2_icon_cache_update
+}