aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-11-12 17:41:24 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-11-12 20:20:26 +0100
commit3e304ee5201bc38000ebab13a27c742841fffd66 (patch)
tree12cb465b0dc7fac772843c962d6147fd14d713ba /dev-qt/linguist
parentdev-qt: Drop Qt 5.13 stable branch (diff)
downloadqt-3e304ee5201bc38000ebab13a27c742841fffd66.tar.gz
qt-3e304ee5201bc38000ebab13a27c742841fffd66.tar.bz2
qt-3e304ee5201bc38000ebab13a27c742841fffd66.zip
dev-qt: Add Qt 5.14.0_beta3
Package-Manager: Portage-2.3.79, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/linguist')
-rw-r--r--dev-qt/linguist/Manifest1
-rw-r--r--dev-qt/linguist/linguist-5.14.0_beta3.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-qt/linguist/Manifest b/dev-qt/linguist/Manifest
index f8c21c53..318df2d8 100644
--- a/dev-qt/linguist/Manifest
+++ b/dev-qt/linguist/Manifest
@@ -1 +1,2 @@
DIST qttools-everywhere-src-5.14.0-beta2.tar.xz 9125244 BLAKE2B 7d27c15af35c80277f322b862187abaadd8d25f3341d1975e2942021ba31b5763ad08c2b681f6f0dee32843864b11495ce7ad2bad7685c922f103fc580d70e75 SHA512 48e44b427916ed2b397f3f17f12b71939d4ed150848447e28a5c96704647ac7c7512dd872ad5d616bba68d65cef4238900215ff546d9da86354b7f94acf91481
+DIST qttools-everywhere-src-5.14.0-beta3.tar.xz 9125292 BLAKE2B ff1171cc962a6f4690b41ac52641b59b67ff611e4f54609836290769f32da9b8b063d59ee5ceacd3d6fadba2af3728aa515679b3832b7a500c929f8dc4064a1b SHA512 82975f7c4dec7646be69b33cbd82ba5a117478c92123ed9ae26c0a8acd87bcbc14e98835ce2e1935cfe8ba9537a3f469be46b69de8050dfe045b804db20d13d1
diff --git a/dev-qt/linguist/linguist-5.14.0_beta3.ebuild b/dev-qt/linguist/linguist-5.14.0_beta3.ebuild
new file mode 100644
index 00000000..af542e66
--- /dev/null
+++ b/dev-qt/linguist/linguist-5.14.0_beta3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+QT5_MODULE="qttools"
+inherit desktop qt5-build xdg-utils
+
+DESCRIPTION="Graphical tool for translating Qt applications"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~x86"
+fi
+
+IUSE=""
+
+DEPEND="
+ ~dev-qt/designer-${PV}
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtgui-${PV}
+ ~dev-qt/qtprintsupport-${PV}
+ ~dev-qt/qtwidgets-${PV}
+ ~dev-qt/qtxml-${PV}
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/linguist/linguist
+)
+
+src_install() {
+ qt5-build_src_install
+
+ local size
+ for size in 16 32 48 64 128; do
+ newicon -s ${size} src/linguist/linguist/images/icons/linguist-${size}-32.png linguist.png
+ done
+ make_desktop_entry "${QT5_BINDIR}"/linguist 'Qt 5 Linguist' linguist 'Qt;Development;Translation'
+}
+
+pkg_postinst() {
+ qt5-build_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ qt5-build_pkg_postrm
+ xdg_icon_cache_update
+}