aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-04-20 20:35:02 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-04-20 20:35:02 +0200
commit74f9320a877a8e04bd88427e9ec5fe1724ed2206 (patch)
tree087fd0c899d76eb6aa2b4cf75d515006e078d0a9 /dev-qt/qtlocation
parentdev-qt: Drop Qt 5.14 stable branch (diff)
downloadqt-74f9320a877a8e04bd88427e9ec5fe1724ed2206.tar.gz
qt-74f9320a877a8e04bd88427e9ec5fe1724ed2206.tar.bz2
qt-74f9320a877a8e04bd88427e9ec5fe1724ed2206.zip
dev-qt: Add Qt 5.15.0_beta4
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtlocation')
-rw-r--r--dev-qt/qtlocation/Manifest1
-rw-r--r--dev-qt/qtlocation/qtlocation-5.15.0_beta4.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/Manifest b/dev-qt/qtlocation/Manifest
index 7fc3e046..24e99cce 100644
--- a/dev-qt/qtlocation/Manifest
+++ b/dev-qt/qtlocation/Manifest
@@ -1 +1,2 @@
DIST qtlocation-everywhere-src-5.15.0-beta3.tar.xz 6542356 BLAKE2B 5b41735de1dfc1f31872a3d6eee058a0971abdf119fec5ed6a94fd7a1d958708c1fd354f14f33f23add4b21431865cd3cee8c613c7f2c539039e732cb4b40e42 SHA512 f59bf6587d1315af478dfe726539b17cd056a56e9a94f55622cb341e016335fdfc98427f15ea79f4397fe28ebebf0cb3d55a56879c78ab86acb405081decf973
+DIST qtlocation-everywhere-src-5.15.0-beta4.tar.xz 6543168 BLAKE2B adf193f112dd835826cc0f6a5b13c47a80655be498b989c9d190fc2687ca719b236e869ff618cdc81f1d5846daf75c1d515554f0d067535eebeaacddb3daabe6 SHA512 58752cd637fc508732d605b12ef3911ad4e9db5d75360f81b398e810b8f2fdf39dc6ed1f2616363d93b57231edbf657b0dedcf0da1cf0250c4d9ce9827714ac6
diff --git a/dev-qt/qtlocation/qtlocation-5.15.0_beta4.ebuild b/dev-qt/qtlocation/qtlocation-5.15.0_beta4.ebuild
new file mode 100644
index 00000000..0772e510
--- /dev/null
+++ b/dev-qt/qtlocation/qtlocation-5.15.0_beta4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit qt5-build
+
+DESCRIPTION="Location (places, maps, navigation) library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+IUSE=""
+
+RDEPEND="
+ dev-libs/icu:=
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdeclarative-${PV}
+ ~dev-qt/qtgui-${PV}
+ ~dev-qt/qtnetwork-${PV}
+ ~dev-qt/qtpositioning-${PV}[qml]
+ ~dev-qt/qtsql-${PV}
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ ~dev-qt/qtconcurrent-${PV}
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/3rdparty/clipper
+ src/3rdparty/poly2tri
+ src/3rdparty/clip2tri
+ src/3rdparty/mapbox-gl-native
+ src/location
+ src/imports/location
+ src/imports/locationlabs
+ src/plugins/geoservices
+)
+
+src_configure() {
+ # src/plugins/geoservices requires files that are only generated when
+ # qmake is run in the root directory. Bug 633776.
+ mkdir -p "${QT5_BUILD_DIR}"/src/location || die
+ qt5_qmake "${QT5_BUILD_DIR}"
+ cp "${S}"/src/location/qtlocation-config.pri "${QT5_BUILD_DIR}"/src/location || die
+ qt5-build_src_configure
+}