aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-09-06 22:51:50 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-09-06 22:51:50 +0200
commitbe5e505fd09ea261c90302435de287d6343b515d (patch)
treee871ccf9f33bec1a6d067f5003a97633186ec643 /dev-qt/qtlocation
parentdev-qt: add 5.15.9999 (diff)
downloadqt-be5e505fd09ea261c90302435de287d6343b515d.tar.gz
qt-be5e505fd09ea261c90302435de287d6343b515d.tar.bz2
qt-be5e505fd09ea261c90302435de287d6343b515d.zip
dev-qt: Add Qt 5.13.1
Package-Manager: Portage-2.3.75, Repoman-2.3.17 RepoMan-Options: --force Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtlocation')
-rw-r--r--dev-qt/qtlocation/Manifest1
-rw-r--r--dev-qt/qtlocation/qtlocation-5.13.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/Manifest b/dev-qt/qtlocation/Manifest
new file mode 100644
index 00000000..80233715
--- /dev/null
+++ b/dev-qt/qtlocation/Manifest
@@ -0,0 +1 @@
+DIST qtlocation-everywhere-src-5.13.1.tar.xz 6115116 BLAKE2B 5e83c3aa7a88332644bc40a4dff8a8eb8e47e0ac244cdc231658e4565999f4bafaa2692a4343e71f166031c968d1ad9b702da782b0ff55f25eac16a3440fd4fb SHA512 661ceff9ebb757e58e9430e0af86e782445029d42da61769264d5706c6633e42bf064c0afdb657e01dd2e3d9edd73e02dbadac2e65820038bbbcc3990a8e35aa
diff --git a/dev-qt/qtlocation/qtlocation-5.13.1.ebuild b/dev-qt/qtlocation/qtlocation-5.13.1.ebuild
new file mode 100644
index 00000000..ff48cdc6
--- /dev/null
+++ b/dev-qt/qtlocation/qtlocation-5.13.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit qt5-build
+
+DESCRIPTION="Location (places, maps, navigation) library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+IUSE=""
+
+RDEPEND="
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdeclarative-${PV}
+ ~dev-qt/qtgui-${PV}
+ ~dev-qt/qtnetwork-${PV}
+ ~dev-qt/qtpositioning-${PV}[qml]
+ ~dev-qt/qtsql-${PV}
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ ~dev-qt/qtconcurrent-${PV}
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/3rdparty/clipper
+ src/3rdparty/poly2tri
+ src/3rdparty/clip2tri
+ src/3rdparty/mapbox-gl-native
+ src/location
+ src/imports/location
+ src/imports/locationlabs
+ src/plugins/geoservices
+)
+
+src_configure() {
+ # src/plugins/geoservices requires files that are only generated when
+ # qmake is run in the root directory. Bug 633776.
+ mkdir -p "${QT5_BUILD_DIR}" || die
+ qt5_qmake "${QT_BUILD_DIR}"
+ qt5-build_src_configure
+}