aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-05-29 15:50:55 +0300
committerMarkos Chandras <hwoarang@gentoo.org>2009-05-29 15:50:55 +0300
commit394fc19440a6c9da9b88f593df2cd9d0c16a90c0 (patch)
tree7ce15cad38dec12ff8eba49298be4df989f88a82 /media-sound
parentPyQt4: Allow media-sound/phonon to satisfy phonon dependency (diff)
downloadqt-394fc19440a6c9da9b88f593df2cd9d0c16a90c0.tar.gz
qt-394fc19440a6c9da9b88f593df2cd9d0c16a90c0.tar.bz2
qt-394fc19440a6c9da9b88f593df2cd9d0c16a90c0.zip
qmpdclient/qt4-edge.eclass: Ebuild clean up,use qt4-edge default functions / More fixes on translations
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/qmpdclient/ChangeLog3
-rw-r--r--media-sound/qmpdclient/Manifest4
-rw-r--r--media-sound/qmpdclient/qmpdclient-9999.ebuild39
3 files changed, 10 insertions, 36 deletions
diff --git a/media-sound/qmpdclient/ChangeLog b/media-sound/qmpdclient/ChangeLog
index cd8a5a16..bd62b47f 100644
--- a/media-sound/qmpdclient/ChangeLog
+++ b/media-sound/qmpdclient/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 29 May 2009; Markos Chandras <hwoarang@gentoo.org> qmpdclient-9999.ebuild:
+ Ebuild clean up . Make it compatible with qt4-edge eclass
+
19 May 2009; Markos Chandras <hwoarang@gentoo.org> qmpdclient-9999.ebuild:
Fix dbus automagic dependency check
diff --git a/media-sound/qmpdclient/Manifest b/media-sound/qmpdclient/Manifest
index 5eee764c..dbe810ce 100644
--- a/media-sound/qmpdclient/Manifest
+++ b/media-sound/qmpdclient/Manifest
@@ -1,2 +1,2 @@
-EBUILD qmpdclient-9999.ebuild 2444 RMD160 b4e70c38a8810579220d15a1899f74a0b52687ea SHA1 cefd7dc6487fc7785f22c47d358d7c434583cec5 SHA256 6688c88422b71455c07761fed2d9deafdd1e57717759bda8530d8cf680113b1a
-MISC ChangeLog 1895 RMD160 8b951d90d9d43eca5c072ccd3c6cbb1dee6752e9 SHA1 c7346e07f214e19ccd96ab7cbefc9346cd4ec597 SHA256 594620fcdd27ac0df355ef6c0914f41a308463c968642127ce7ade79b7349fb1
+EBUILD qmpdclient-9999.ebuild 1808 RMD160 a4debf88971940b671b31d30c0c4d25ee4650f32 SHA1 4e551377362f75ff5b15413835700f08875e222b SHA256 f9320fdf0fcc52222b00c74e950118fe254e2fa191f2f80b750e60a1f79a9839
+MISC ChangeLog 2033 RMD160 65690b8674ae12ba5973e81f39058ca51d1aac0e SHA1 c9fc3eede7c23bf9de6d72ff3c9cb6c9c9cb3026 SHA256 d1bc6cf063d24fadad19691eec9fca28d793df76b754055b5280f0f57fc11b60
diff --git a/media-sound/qmpdclient/qmpdclient-9999.ebuild b/media-sound/qmpdclient/qmpdclient-9999.ebuild
index 6d0ab27a..bcd12492 100644
--- a/media-sound/qmpdclient/qmpdclient-9999.ebuild
+++ b/media-sound/qmpdclient/qmpdclient-9999.ebuild
@@ -4,6 +4,8 @@
EAPI="2"
EGIT_REPO_URI="git://github.com/Voker57/qmpdclient-ne.git"
+LANGS="de_DE fr_FR it_IT nl_NL nn_NO no_NO ru_RU sv_SE tr_TR uk_UA"
+LANGSLONG="zh_CN zh_TW pt_BR"
inherit qt4-edge git
@@ -17,17 +19,7 @@ IUSE="debug dbus"
DEPEND="x11-libs/qt-gui:4[dbus?]"
RDEPEND="${DEPEND}"
-
-LANGS="de_DE fr_FR it_IT nl_NL nn_NO no_NO ru_RU sv_SE tr_TR uk_UA"
-LANGSLONG="zh_CN zh_TW pt_BR"
-
-for X in ${LANGS}; do
- IUSE="${IUSE} linguas_${X%_*}"
-done
-
-for X in ${LANGSLONG};do
- IUSE="${IUSE} linguas_${X}"
-done
+DOCS="README AUTHORS THANKSTO Changelog"
src_prepare() {
# Fix the install path
@@ -54,18 +46,13 @@ src_prepare() {
fi
}
-src_configure() {
- eqmake4 qmpdclient.pro
-}
-
src_compile() {
- emake || die "emake failed"
+ qt4-edge_src_compile
emake translate || die "failed to generate translations"
}
src_install() {
- emake install INSTALL_ROOT="${D}" || die "emake install failed"
- dodoc README AUTHORS THANKSTO Changelog || die "Installing docs failed"
+ qt4-edge_src_install
for res in 16 22 64 ; do
insinto /usr/share/icons/hicolor/${res}x${res}/apps/
newins icons/qmpdclient${res}.png ${PN}.png || die "Installing icons failed"
@@ -73,20 +60,4 @@ src_install() {
make_desktop_entry qmpdclient "QMPDClient" ${PN} \
"Qt;AudioVideo;Audio;" || die "Installing desktop entry failed"
-
- #install translations
- insinto /usr/share/${PN}/translations/
- local LANG=
- for LANG in ${LINGUAS};do
- for X in ${LANGS};do
- if [[ ${LANG} == ${X%_*} ]];then
- doins -r lang/${X}.qm || die "failed to install translations"
- fi
- done
- for X in ${LANGSLONG};do
- if [[ ${LANG} == ${X} ]]; then
- doins -r lang/${X}.qm || die "failed to install translations"
- fi
- done
- done
}