aboutsummaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtwebengine/files/qtwebengine-5.15.13_p20240510-gcc15.patch35
-rw-r--r--dev-qt/qtwebengine/qtwebengine-5.15.16.9999.ebuild1
2 files changed, 0 insertions, 36 deletions
diff --git a/dev-qt/qtwebengine/files/qtwebengine-5.15.13_p20240510-gcc15.patch b/dev-qt/qtwebengine/files/qtwebengine-5.15.13_p20240510-gcc15.patch
deleted file mode 100644
index d3073b6c..00000000
--- a/dev-qt/qtwebengine/files/qtwebengine-5.15.13_p20240510-gcc15.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-https://bugs.gentoo.org/936416
-
-Backport of two upstream commits:
-* https://chromium-review.googlesource.com/c/chromium/src/+/5512719
-* https://quiche.googlesource.com/quiche/+/c1af894e0f5c4f732a983e7c93227854e203570e%5E%21/#F0
---- a/src/3rdparty/chromium/base/containers/id_map.h
-+++ b/src/3rdparty/chromium/base/containers/id_map.h
-@@ -153,8 +153,8 @@ class IDMap final {
- }
-
- const Iterator& operator=(const Iterator& iter) {
-- map_ = iter.map;
-- iter_ = iter.iter;
-+ map_ = iter.map_;
-+ iter_ = iter.iter_;
- Init();
- return *this;
- }
---- a/src/3rdparty/chromium/net/third_party/quiche/src/quic/core/quic_interval_deque.h
-+++ b/src/3rdparty/chromium/net/third_party/quiche/src/quic/core/quic_interval_deque.h
-@@ -198,12 +198,12 @@ class QUIC_NO_EXPORT QuicIntervalDeque {
- Iterator operator+(difference_type amount) const {
- Iterator copy = *this;
- copy.index_ += amount;
-- DCHECK(copy.index_ < copy.deque_->size());
-+ DCHECK(copy.index_ < copy.deque_->Size());
- return copy;
- }
- Iterator& operator+=(difference_type amount) {
- index_ += amount;
-- DCHECK(index_ < deque_->size());
-+ DCHECK(index_ < deque_->Size());
- return *this;
- }
- difference_type operator-(const Iterator& rhs) const {
diff --git a/dev-qt/qtwebengine/qtwebengine-5.15.16.9999.ebuild b/dev-qt/qtwebengine/qtwebengine-5.15.16.9999.ebuild
index 3833e554..eb2dc1c5 100644
--- a/dev-qt/qtwebengine/qtwebengine-5.15.16.9999.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-5.15.16.9999.ebuild
@@ -100,7 +100,6 @@ BDEPEND="${PYTHON_DEPS}
PATCHES=(
"${WORKDIR}/${PATCHSET}"
- "${FILESDIR}/${PN}-5.15.13_p20240510-gcc15.patch"
"${FILESDIR}/${PN}-5.15.14_p20240510-re2.patch" # bug 913923
"${FILESDIR}/${PN}-5.15.14_p20240510-gcc15-cstdint.patch"
"${FILESDIR}/${PN}-5.15.14_p20240510-gcc15-template-id-cdtor.patch"