aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2019-05-03 00:25:10 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2019-05-03 00:25:10 +0200
commit4d79e4909ed110cddbe65129ca529645e6e1a19c (patch)
treee8466226056ea9ae695e748cbd736de43b479de7 /dev-lang/python/files/python-2.7.10-system-libffi.patch
parentprofiles: Really only python-3.7 (diff)
downloadriscv-4d79e4909ed110cddbe65129ca529645e6e1a19c.tar.gz
riscv-4d79e4909ed110cddbe65129ca529645e6e1a19c.tar.bz2
riscv-4d79e4909ed110cddbe65129ca529645e6e1a19c.zip
dev-lang/python: drop, not needed anymore
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-lang/python/files/python-2.7.10-system-libffi.patch')
-rw-r--r--dev-lang/python/files/python-2.7.10-system-libffi.patch36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-lang/python/files/python-2.7.10-system-libffi.patch b/dev-lang/python/files/python-2.7.10-system-libffi.patch
deleted file mode 100644
index 0b49b79..0000000
--- a/dev-lang/python/files/python-2.7.10-system-libffi.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-make sure we respect the system libffi setting in our build config.
-the compiler probing is fragile and can break in some situations.
-
---- a/setup.py
-+++ b/setup.py
-@@ -2069,7 +2069,7 @@ class PyBuildExt(build_ext):
- return True
-
- def detect_ctypes(self, inc_dirs, lib_dirs):
-- self.use_system_libffi = False
-+ self.use_system_libffi = ('--with-system-ffi' in sysconfig.get_config_var("CONFIG_ARGS"))
- include_dirs = []
- extra_compile_args = []
- extra_link_args = []
-@@ -2113,7 +2113,7 @@ class PyBuildExt(build_ext):
- sources=['_ctypes/_ctypes_test.c'])
- self.extensions.extend([ext, ext_test])
-
-- if not '--with-system-ffi' in sysconfig.get_config_var("CONFIG_ARGS"):
-+ if not self.use_system_libffi:
- return
-
- if host_platform == 'darwin':
-@@ -2141,10 +2141,10 @@ class PyBuildExt(build_ext):
- ffi_lib = lib_name
- break
-
-- if ffi_inc and ffi_lib:
-+ if ffi_inc:
- ext.include_dirs.extend(ffi_inc)
-+ if ffi_lib:
- ext.libraries.append(ffi_lib)
-- self.use_system_libffi = True
-
-
- class PyBuildInstall(install):