summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2009-09-09 16:41:35 +0200
committerAlex Legler <a3li@gentoo.org>2009-09-09 16:41:35 +0200
commit6becacd4812dbee9d04ca1115fa275df9c225dee (patch)
treea6862e8f4d778677df17418f4d10d3488f0733a5 /patchsets
parentRemoving the b0rked mkrelease.rb (diff)
downloadruby-scripts-6becacd4812dbee9d04ca1115fa275df9c225dee.tar.gz
ruby-scripts-6becacd4812dbee9d04ca1115fa275df9c225dee.tar.bz2
ruby-scripts-6becacd4812dbee9d04ca1115fa275df9c225dee.zip
Adding 1.9.1_p243 patchset
Diffstat (limited to 'patchsets')
-rw-r--r--patchsets/patches-1.9.1_p243/003_mkmf-parallel-install.patch22
-rw-r--r--patchsets/patches-1.9.1_p243/004_gfbsd7.patch39
-rw-r--r--patchsets/patches-1.9.1_p243/005_no-undefined-ext.patch13
-rw-r--r--patchsets/patches-1.9.1_p243/100_rubygems-proxy.patch11
-rw-r--r--patchsets/patches-1.9.1_p243/101_rubygems-gentoo.patch41
-rw-r--r--patchsets/patches-1.9.1_p243/102_dl-parallelmake.patch14
6 files changed, 140 insertions, 0 deletions
diff --git a/patchsets/patches-1.9.1_p243/003_mkmf-parallel-install.patch b/patchsets/patches-1.9.1_p243/003_mkmf-parallel-install.patch
new file mode 100644
index 0000000..569091d
--- /dev/null
+++ b/patchsets/patches-1.9.1_p243/003_mkmf-parallel-install.patch
@@ -0,0 +1,22 @@
+Fixing parallel make, bug 279825. Patch by <flameeyes@gentoo.org>
+
+Index: ruby-1.9.1-p243/lib/mkmf.rb
+===================================================================
+--- ruby-1.9.1-p243.orig/lib/mkmf.rb
++++ ruby-1.9.1-p243/lib/mkmf.rb
+@@ -1681,6 +1681,7 @@ static: $(STATIC_LIB)#{$extout ? " insta
+ mfile.print "\t@-$(RMDIRS) #{fseprepl[dir]}\n"
+ else
+ mfile.print "#{dest}: #{f}\n"
++ mfile.print "\t@$(MAKEDIRS) #{dir}\n"
+ mfile.print "\t$(INSTALL_PROG) #{fseprepl[f]} #{fseprepl[dir]}\n"
+ if defined?($installed_list)
+ mfile.print "\t@echo #{dir}/#{File.basename(f)}>>$(INSTALLED_LIST)\n"
+@@ -1704,6 +1705,7 @@ static: $(STATIC_LIB)#{$extout ? " insta
+ dest = "#{dir}/#{File.basename(f)}"
+ mfile.print("install-rb#{sfx}: #{dest}\n")
+ mfile.print("#{dest}: #{f}\n")
++ mfile.print "\t@$(MAKEDIRS) #{dir}\n"
+ mfile.print("\t$(#{$extout ? 'COPY' : 'INSTALL_DATA'}) ")
+ mfile.print("#{fseprepl[f]} $(@D#{sep})\n")
+ if defined?($installed_list) and !$extout
diff --git a/patchsets/patches-1.9.1_p243/004_gfbsd7.patch b/patchsets/patches-1.9.1_p243/004_gfbsd7.patch
new file mode 100644
index 0000000..f4d567a
--- /dev/null
+++ b/patchsets/patches-1.9.1_p243/004_gfbsd7.patch
@@ -0,0 +1,39 @@
+Index: ruby-1.9.1-p129/configure.in
+===================================================================
+--- ruby-1.9.1-p129.orig/configure.in
++++ ruby-1.9.1-p129/configure.in
+@@ -1294,7 +1294,7 @@ if test "$rb_cv_binary_elf" = yes; then
+ fi
+
+ case "$target_os" in
+-linux* | gnu* | k*bsd*-gnu | bsdi*)
++linux* | gnu* | k*bsd*-gnu | bsdi* | freebsd* | dragonfly* )
+ if test "$rb_cv_binary_elf" = no; then
+ with_dln_a_out=yes
+ else
+@@ -1381,7 +1381,7 @@ if test "$with_dln_a_out" != yes; then
+ *shlicc*) : ${LDSHARED="$CC -r"}
+ rb_cv_dlopen=yes ;;
+ esac ;;
+- linux* | gnu* | k*bsd*-gnu | netbsd* | bsdi*)
++ linux* | gnu* | k*bsd*-gnu | netbsd* | bsdi* | freebsd7*)
+ : ${LDSHARED='${CC} -shared'}
+ if test "$rb_cv_binary_elf" = yes; then
+ LDFLAGS="$LDFLAGS -Wl,-export-dynamic"
+@@ -1393,7 +1393,6 @@ if test "$with_dln_a_out" != yes; then
+ rb_cv_dlopen=yes ;;
+ freebsd*|dragonfly*) : ${LDSHARED="$CC -shared"}
+ if test "$rb_cv_binary_elf" = yes; then
+- LDFLAGS="$LDFLAGS -rdynamic"
+ DLDFLAGS="$DLDFLAGS "'-Wl,-soname,$(.TARGET)'
+ else
+ test "$GCC" = yes && test "$rb_cv_prog_gnu_ld" = yes || LDSHARED="ld -Bshareable"
+@@ -1722,7 +1721,7 @@ if test "$enable_shared" = 'yes'; then
+ sunos4*)
+ LIBRUBY_ALIASES='lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR) lib$(RUBY_SO_NAME).so'
+ ;;
+- linux* | gnu* | k*bsd*-gnu | atheos*)
++ linux* | gnu* | k*bsd*-gnu | atheos* | freebsd7* )
+ LIBRUBY_DLDFLAGS='-Wl,-soname,lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR)'
+ LIBRUBY_ALIASES='lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR) lib$(RUBY_SO_NAME).so'
+ ;;
diff --git a/patchsets/patches-1.9.1_p243/005_no-undefined-ext.patch b/patchsets/patches-1.9.1_p243/005_no-undefined-ext.patch
new file mode 100644
index 0000000..08d1876
--- /dev/null
+++ b/patchsets/patches-1.9.1_p243/005_no-undefined-ext.patch
@@ -0,0 +1,13 @@
+Index: ruby-1.9.1-p129/configure.in
+===================================================================
+--- ruby-1.9.1-p129.orig/configure.in
++++ ruby-1.9.1-p129/configure.in
+@@ -1384,7 +1384,7 @@ if test "$with_dln_a_out" != yes; then
+ linux* | gnu* | k*bsd*-gnu | netbsd* | bsdi* | freebsd7*)
+ : ${LDSHARED='${CC} -shared'}
+ if test "$rb_cv_binary_elf" = yes; then
+- LDFLAGS="$LDFLAGS -Wl,-export-dynamic"
++ LDFLAGS="$LDFLAGS -Wl,-export-dynamic -Wl,--no-undefined"
+ fi
+ rb_cv_dlopen=yes ;;
+ interix*) : ${LDSHARED="$CC -shared"}
diff --git a/patchsets/patches-1.9.1_p243/100_rubygems-proxy.patch b/patchsets/patches-1.9.1_p243/100_rubygems-proxy.patch
new file mode 100644
index 0000000..c1719cc
--- /dev/null
+++ b/patchsets/patches-1.9.1_p243/100_rubygems-proxy.patch
@@ -0,0 +1,11 @@
+--- lib/rubygems/remote_fetcher.rb.1 2008-06-21 23:21:17.000000000 +0200
++++ lib/rubygems/remote_fetcher.rb 2008-09-23 20:37:24.000000000 +0200
+@@ -195,7 +195,7 @@
+
+ return nil if env_proxy.nil? or env_proxy.empty?
+
+- uri = URI.parse env_proxy
++ uri = URI.parse normalize_uri env_proxy
+
+ if uri and uri.user.nil? and uri.password.nil? then
+ # Probably we have http_proxy_* variables?
diff --git a/patchsets/patches-1.9.1_p243/101_rubygems-gentoo.patch b/patchsets/patches-1.9.1_p243/101_rubygems-gentoo.patch
new file mode 100644
index 0000000..754d663
--- /dev/null
+++ b/patchsets/patches-1.9.1_p243/101_rubygems-gentoo.patch
@@ -0,0 +1,41 @@
+diff -ru a/lib/rubygems/commands/install_command.rb b/lib/rubygems/commands/install_command.rb
+--- a/lib/rubygems/commands/install_command.rb 2008-09-11 01:54:41.000000000 +0200
++++ b/lib/rubygems/commands/install_command.rb 2008-09-28 10:24:27.000000000 +0200
+@@ -76,6 +76,7 @@
+ :wrappers => options[:wrappers],
+ :bin_dir => options[:bin_dir],
+ :development => options[:development],
++ :sandbox_fix => options[:sandbox_fix],
+ }
+
+ exit_code = 0
+diff -ru a/lib/rubygems/dependency_installer.rb b/lib/rubygems/dependency_installer.rb
+--- a/lib/rubygems/dependency_installer.rb 2008-08-12 23:50:22.000000000 +0200
++++ b/lib/rubygems/dependency_installer.rb 2008-09-28 10:22:21.000000000 +0200
+@@ -40,9 +40,10 @@
+ # :security_policy:: See Gem::Installer::new and Gem::Security.
+ # :user_install:: See Gem::Installer.new
+ # :wrappers:: See Gem::Installer::new
++ # :sandbox_fix:: Gentoo patch to repair compatibility
+
+ def initialize(options = {})
+- if options[:install_dir] then
++ if options[:install_dir] and not options[:sandbox_fix] then
+ spec_dir = options[:install_dir], 'specifications'
+ @source_index = Gem::SourceIndex.from_gems_in spec_dir
+ else
+diff -ru a/lib/rubygems/install_update_options.rb b/lib/rubygems/install_update_options.rb
+--- a/lib/rubygems/install_update_options.rb 2008-06-24 20:56:30.000000000 +0200
++++ b/lib/rubygems/install_update_options.rb 2008-09-28 10:24:09.000000000 +0200
+@@ -83,6 +83,11 @@
+ options[:include_dependencies] = value
+ end
+
++ add_option(:"Install/Update", '--sandbox-fix',
++ 'Fix specifications lookup path [Gentoo patch]') do |value, options|
++ options[:sandbox_fix] = true
++ end
++
+ add_option(:"Install/Update", '--[no-]format-executable',
+ 'Make installed executable names match ruby.',
+ 'If ruby is ruby18, foo_exec will be',
diff --git a/patchsets/patches-1.9.1_p243/102_dl-parallelmake.patch b/patchsets/patches-1.9.1_p243/102_dl-parallelmake.patch
new file mode 100644
index 0000000..60f08d7
--- /dev/null
+++ b/patchsets/patches-1.9.1_p243/102_dl-parallelmake.patch
@@ -0,0 +1,14 @@
+Index: ruby-1.9.1-p129/ext/dl/depend
+===================================================================
+--- ruby-1.9.1-p129.orig/ext/dl/depend
++++ ruby-1.9.1-p129/ext/dl/depend
+@@ -18,7 +18,8 @@ callback-8.o: callback-8.c $(hdrdir)/rub
+
+ callback-0.c callback-1.c callback-2.c \
+ callback-3.c callback-4.c callback-5.c \
+-callback-6.c callback-7.c callback-8.c \
++callback-6.c callback-7.c callback-8.c: callback.h
++
+ callback.h: $(srcdir)/mkcallback.rb dl.h
+ @echo "generating callback.h"
+ @$(RUBY) $(srcdir)/mkcallback.rb $(srcdir)/dl.h