aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2005-11-28 10:52:03 +0000
committerMartin Schlemmer <azarah@gentoo.org>2005-11-28 10:52:03 +0000
commit7561c08cf26eb38ae23b89ed662e7f26ef4c3267 (patch)
tree7fc702b9087d95e84c8a27e75a198d4b76d64ab6 /Makefile.am
parentSandbox 1.2.14 release. (diff)
downloadsandbox-7561c08cf26eb38ae23b89ed662e7f26ef4c3267.tar.gz
sandbox-7561c08cf26eb38ae23b89ed662e7f26ef4c3267.tar.bz2
sandbox-7561c08cf26eb38ae23b89ed662e7f26ef4c3267.zip
Reorder source layout.
Signed-off-by: Martin Schlemmer <azarah@gentoo.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am51
1 files changed, 3 insertions, 48 deletions
diff --git a/Makefile.am b/Makefile.am
index c634ca7..4c4f90e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,50 +1,5 @@
-AUTOMAKE_OPTIONS = dist-bzip2 no-dist-gzip
-EXTRA_DIST = sandbox.bashrc canonicalize.c symbols.in
-CLEANFILES = symbols.h
+AUTOMAKE_OPTIONS = dist-bzip2 no-dist-gzip
-AM_CPPFLAGS = -D_GNU_SOURCE -DPIC -fPIC -D_REENTRANT \
- -DLIBSANDBOX_PATH=\"$(libdir)\" \
- -DSANDBOX_BASHRC_PATH=\"$(pkgdatadir)\"
+SUBDIRS = data src
-dist_pkgdata_DATA = sandbox.bashrc
-
-lib_LTLIBRARIES = libsandbox.la
-libsandbox_la_SOURCES = libsandbox.c localdecls.h
-# Do not add -nostdlib or -nostartfiles, as then our constructor
-# and destructor will not be executed ...
-libsandbox_la_LDFLAGS = -nodefaultlibs -lc -ldl
-# We need -fexceptions here, else we do not catch exceptions
-# (nptl/tst-cancelx4.c in glibc among others fails for wrapped functions).
-libsandbox_la_CFLAGS = -fexceptions
-
-bin_PROGRAMS = sandbox
-sandbox_SOURCES = sandbox.c sandbox.h sandbox_futils.c getcwd.c
-sandbox_CFLAGS = -DOUTSIDE_LIBSANDBOX
-
-libsandbox.c: symbols.h
-
-# Basically generates symbols.h from the function names in symbols.in.
-# Not sure if we can count on the latest version the only symbol
-# countaining '@@' ...
-symbols.h: symbols.in
- @echo "Generating $@"; \
- if [ ! -e "$(LIBC_PATH)" ]; then\
- echo -e "\n*** Cannot find LIBC_PATH '$(LIBC_PATH)' !\n"; \
- exit 1; \
- fi; \
- echo "#ifndef __symbol_h" > $@; \
- echo -e "#define __symbol_h\n" >> $@; \
- for x in `cat $^`; do \
- sym=`readelf -s "$(LIBC_PATH)" 2>/dev/null | \
- awk '{ print $$8 }' | \
- grep "^$${x}@@" | \
- sort -u | \
- cut -d'@' -f3`; \
- echo "#define symname_$${x} \"$${x}\"" >> $@; \
- if [ -n "$${sym}" ]; then \
- echo "#define symver_$${x} \"$${sym}\"" >> $@; \
- else \
- echo "#define symver_$${x} NULL" >> $@; \
- fi; \
- done; \
- echo -e "\n#endif /* __symbol_h */" >> $@
+EXTRA_DIST = localdecls.h