aboutsummaryrefslogtreecommitdiff
path: root/data
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2005-11-28 10:52:03 +0000
committerMartin Schlemmer <azarah@gentoo.org>2005-11-28 10:52:03 +0000
commit7561c08cf26eb38ae23b89ed662e7f26ef4c3267 (patch)
tree7fc702b9087d95e84c8a27e75a198d4b76d64ab6 /data
parentSandbox 1.2.14 release. (diff)
downloadsandbox-7561c08cf26eb38ae23b89ed662e7f26ef4c3267.tar.gz
sandbox-7561c08cf26eb38ae23b89ed662e7f26ef4c3267.tar.bz2
sandbox-7561c08cf26eb38ae23b89ed662e7f26ef4c3267.zip
Reorder source layout.
Signed-off-by: Martin Schlemmer <azarah@gentoo.org>
Diffstat (limited to 'data')
-rw-r--r--data/Makefile.am3
-rw-r--r--data/sandbox.bashrc16
2 files changed, 19 insertions, 0 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
new file mode 100644
index 0000000..d6aa7b4
--- /dev/null
+++ b/data/Makefile.am
@@ -0,0 +1,3 @@
+dist_pkgdata_DATA = sandbox.bashrc
+
+EXTRA_DIST = sandbox.bashrc
diff --git a/data/sandbox.bashrc b/data/sandbox.bashrc
new file mode 100644
index 0000000..39796db
--- /dev/null
+++ b/data/sandbox.bashrc
@@ -0,0 +1,16 @@
+# Copyright (C) 2001 Geert Bevin, Uwyn, http://www.uwyn.com
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author : Geert Bevin <gbevin@uwyn.com>
+# $Header$
+source /etc/profile
+
+if [[ -n ${LD_PRELOAD} && ${LD_PRELOAD} != *$SANDBOX_LIB* ]] ; then
+ export LD_PRELOAD="${SANDBOX_LIB} ${LD_PRELOAD}"
+elif [[ -z ${LD_PRELOAD} ]] ; then
+ export LD_PRELOAD="${SANDBOX_LIB}"
+fi
+
+alias make="make LD_PRELOAD=${LD_PRELOAD}"
+alias su="su -c '/bin/bash -rcfile ${SANDBOX_BASHRC}'"
+
+declare -r SANDBOX_ACTIVE