aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-06-22 14:31:34 -0700
committerMike Frysinger <vapier@gentoo.org>2012-07-03 00:38:40 -0400
commitb9cfa0a10decdbe659447a221a0634f2b78943b0 (patch)
tree47aa5b2a61934e7f85100e43515e6e889e436995 /libsbutil
parentsb_printf: expand feature set slightly and fix testing (diff)
downloadsandbox-b9cfa0a10decdbe659447a221a0634f2b78943b0.tar.gz
sandbox-b9cfa0a10decdbe659447a221a0634f2b78943b0.tar.bz2
sandbox-b9cfa0a10decdbe659447a221a0634f2b78943b0.zip
precompile headers.h to speed up build slightly
Since all system headers are included by way of headers.h, we can pre-compile this to speed up the build up a bit. Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'libsbutil')
-rw-r--r--libsbutil/Makefile.am1
-rw-r--r--libsbutil/headers.h1
2 files changed, 2 insertions, 0 deletions
diff --git a/libsbutil/Makefile.am b/libsbutil/Makefile.am
index 49a7d3b..a93b95c 100644
--- a/libsbutil/Makefile.am
+++ b/libsbutil/Makefile.am
@@ -44,3 +44,4 @@ libsbutil_la_SOURCES = \
src/dynbuf.c \
$(LOCAL_INCLUDES)
+EXTRA_DIST = headers.h
diff --git a/libsbutil/headers.h b/libsbutil/headers.h
new file mode 100644
index 0000000..7fcc3b2
--- /dev/null
+++ b/libsbutil/headers.h
@@ -0,0 +1 @@
+#include "../headers.h"