aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Schubert <mschu.dev@gmail.com>2024-06-17 11:48:29 +0000
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-06-19 12:14:17 +0200
commit0b4b41e332a801887762104b159d19ffd5227906 (patch)
tree388bcf441e6a5eaf31295198af83c609e42d078d
parentdev-python/snakemake-report-plugins: add ebuild (diff)
downloadsci-0b4b41e332a801887762104b159d19ffd5227906.tar.gz
sci-0b4b41e332a801887762104b159d19ffd5227906.tar.bz2
sci-0b4b41e332a801887762104b159d19ffd5227906.zip
dev-python/snakemake-storage-plugins: add ebuild
Signed-off-by: Michael Schubert <mschu.dev@gmail.com> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/snakemake-interface-storage-plugins/Manifest1
-rw-r--r--dev-python/snakemake-interface-storage-plugins/metadata.xml16
-rw-r--r--dev-python/snakemake-interface-storage-plugins/snakemake-interface-storage-plugins-3.2.2.ebuild24
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/snakemake-interface-storage-plugins/Manifest b/dev-python/snakemake-interface-storage-plugins/Manifest
new file mode 100644
index 000000000..543284907
--- /dev/null
+++ b/dev-python/snakemake-interface-storage-plugins/Manifest
@@ -0,0 +1 @@
+DIST snakemake_interface_storage_plugins-3.2.2.tar.gz 11949 BLAKE2B 56e33546c1a9a0eeb92560ff2eb3950b2b91edaa5c527b4b504082bd2ed3f0fbd1b8e8cd24d1391375e99c2b2041aa47a30ac62dd009ec1188cffee65fa606cb SHA512 0151f297ae5f597016e02937021af2583982d5df0cb0c353274618799f68a4a99a30a19f631f1a8c4dabf74833f39c47a4405f7c0e9be8b3397ae350ae23e62d
diff --git a/dev-python/snakemake-interface-storage-plugins/metadata.xml b/dev-python/snakemake-interface-storage-plugins/metadata.xml
new file mode 100644
index 000000000..8b49faffd
--- /dev/null
+++ b/dev-python/snakemake-interface-storage-plugins/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mschu.dev@gmail.com</email>
+ <name>Michael Schubert</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">snakemake/snakemake-interface-storage-plugins</remote-id>
+ <remote-id type="pypi">snakemake-interface-storage-plugins</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/snakemake-interface-storage-plugins/snakemake-interface-storage-plugins-3.2.2.ebuild b/dev-python/snakemake-interface-storage-plugins/snakemake-interface-storage-plugins-3.2.2.ebuild
new file mode 100644
index 000000000..39c8b08a2
--- /dev/null
+++ b/dev-python/snakemake-interface-storage-plugins/snakemake-interface-storage-plugins-3.2.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit pypi distutils-r1
+
+DESCRIPTION="Stable interface for interactions between Snakemake and its storage plugins"
+HOMEPAGE="https://pypi.org/project/snakemake-interface-storage-plugins/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-python/snakemake-interface-common[${PYTHON_USEDEP}]
+ dev-python/wrapt[${PYTHON_USEDEP}]
+ dev-python/reretry[${PYTHON_USEDEP}]
+ dev-python/throttler[${PYTHON_USEDEP}]"
+
+RESTRICT="test" # no tests collected
+#distutils_enable_tests pytest