aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-10-19 10:49:25 +0200
committerAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-10-22 10:32:08 +0200
commit52f94cf6540a9352a2fe72e54189bea80b3808da (patch)
treec40a97598f06656164c6616a11ff668db359b4ba
parentsci-biology/trimmomatic: unkeyword 0.39 for ~x86 (diff)
downloadsci-52f94cf6540a9352a2fe72e54189bea80b3808da.tar.gz
sci-52f94cf6540a9352a2fe72e54189bea80b3808da.tar.bz2
sci-52f94cf6540a9352a2fe72e54189bea80b3808da.zip
dev-python/uhi: add 0.5.0
Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de>
-rw-r--r--dev-python/uhi/Manifest1
-rw-r--r--dev-python/uhi/uhi-0.5.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/uhi/Manifest b/dev-python/uhi/Manifest
index 199ee2a62..7eeab5dbb 100644
--- a/dev-python/uhi/Manifest
+++ b/dev-python/uhi/Manifest
@@ -1 +1,2 @@
DIST uhi-0.4.0.tar.gz 52953 BLAKE2B b0c16c58c676f405d7b46398507968e92e4c3939a53224b49cbd935c3473800341903a9e9c5e3c598d68f171a9ec098feedaa774b2bbfe780581a663e99b2592 SHA512 4f7f0bdce3fef14c8789e0860956d6d4d2ab91e48eb95b6bceb67aef47b23a260f0f33a565c052fe48933f108adfe32f4c28c8cf874cc908929d407687bbc385
+DIST uhi-0.5.0.tar.gz 25769 BLAKE2B a920a17671bb98ee809264c762189feefc0eaed8b24b616e726fa646728c9ca8cfa518077d9b6e94c55505ea41d6dcbd7c937fd4407c80e8995df80ccdfeec54 SHA512 97bd42b9135360888488106554c9c3ad042b0e4f7eabc7abf7edadec978261032c40ab43e3e1c4df7aa6b4447f403085767b4d9beb5c9bdc50466e049a9d3080
diff --git a/dev-python/uhi/uhi-0.5.0.ebuild b/dev-python/uhi/uhi-0.5.0.ebuild
new file mode 100644
index 000000000..7dee1e062
--- /dev/null
+++ b/dev-python/uhi/uhi-0.5.0.ebuild
@@ -0,0 +1,27 @@
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+DISTUTILS_USE_PEP517=hatchling
+SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+inherit distutils-r1 pypi
+
+DESCRIPTION="Universal Histogram Interface"
+HOMEPAGE="https://github.com/scikit-hep/uhi"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/numpy-1.13.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/fastjsonschema[${PYTHON_USEDEP}]
+ >=dev-python/boost-histogram-1.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest