aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-06-03 10:07:50 +0200
committerAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-06-03 10:07:50 +0200
commite193385eaeb6594e8be0d1077bcfb13c1b64f282 (patch)
treebeb9557e243642973b8cbb5348ba0d64349c7c68
parentsci-physics/qgraf: add 4.0.1 (diff)
downloadsci-e193385eaeb6594e8be0d1077bcfb13c1b64f282.tar.gz
sci-e193385eaeb6594e8be0d1077bcfb13c1b64f282.tar.bz2
sci-e193385eaeb6594e8be0d1077bcfb13c1b64f282.zip
dev-python/hist: add 2.7.3
Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de>
-rw-r--r--dev-python/hist/Manifest1
-rw-r--r--dev-python/hist/hist-2.7.3.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/hist/Manifest b/dev-python/hist/Manifest
index 722ab9aa8..f9d572709 100644
--- a/dev-python/hist/Manifest
+++ b/dev-python/hist/Manifest
@@ -1 +1,2 @@
DIST hist-2.7.2.tar.gz 991866 BLAKE2B 6785114e1a5b3e38b9917c5d8b660e6d03dbe56d7a3238c971686ffc03ec1e9c6361ea6ed73ed61b10a4074b13d4ad785b676a61a856069ba23789985949787e SHA512 92a320a80509eaeaa496c2713b349e3b1442c46a7aeda04e362fdd692aea3f43f06e5bdb35293ca70f9b24536c24494fa1c806e9f9e8573559c13abeee22c4ce
+DIST hist-2.7.3.tar.gz 992241 BLAKE2B 865e4a7d65633c42d114139390040872d630527292f2941eb70732c1456d5f2571026d2a131f0bc09015a5922d6f6557342f4fb00ec91eeb83bb8b2bc25f28fd SHA512 85c7231f2cbc7bd8d7066f664a8fe9cd54092f79a242c353bdf3fad47ae7040f52b836238a92f006cdf30d2a3ae1e3a0c6bc1d8afaf2004f2056f6da5398d2b2
diff --git a/dev-python/hist/hist-2.7.3.ebuild b/dev-python/hist/hist-2.7.3.ebuild
new file mode 100644
index 000000000..082844a5f
--- /dev/null
+++ b/dev-python/hist/hist-2.7.3.ebuild
@@ -0,0 +1,26 @@
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=hatchling
+SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+inherit distutils-r1 pypi
+
+DESCRIPTION="Histogramming for analysis powered by boost-histogram "
+HOMEPAGE="https://github.com/scikit-hep/hist"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/boost-histogram-1.3.1[${PYTHON_USEDEP}]
+ >=dev-python/histoprint-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.14.5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+RESTRICT="test"
+# needs mplhep and dask_histogram ...
+#distutils_enable_tests pytest