aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfgang E. Sanyer <WolfgangESanyer@gmail.com>2021-01-22 23:55:41 -0500
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-02-23 09:31:37 +0100
commit42b48870ea2fbe45aaedc5be1bc9ee2b175fef7a (patch)
tree824b9d975d086fddb348a8b1897c83c1b5155994 /app-office
parentnet-misc/cernbox-client: Drop old version. (diff)
downloadsci-42b48870ea2fbe45aaedc5be1bc9ee2b175fef7a.tar.gz
sci-42b48870ea2fbe45aaedc5be1bc9ee2b175fef7a.tar.bz2
sci-42b48870ea2fbe45aaedc5be1bc9ee2b175fef7a.zip
app-office/visidata: bump to 2.1.1
Signed-off-by: Wolfgang E. Sanyer <WolfgangESanyer@gmail.com> Closes: https://github.com/gentoo/sci/pull/1041 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/visidata/Manifest1
-rw-r--r--app-office/visidata/visidata-2.1.1.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/app-office/visidata/Manifest b/app-office/visidata/Manifest
index 23e0d08fc..42921ce64 100644
--- a/app-office/visidata/Manifest
+++ b/app-office/visidata/Manifest
@@ -1 +1,2 @@
DIST visidata-1.5.2.tar.gz 637598 BLAKE2B 47ef05280cec9fdb3620759b7c2089de7d2e42a4a1d1a13d14b5e59555c8de6091ceab1fb72ab4ee45dc7611741ffdc6eeefcab5e4755485b6d18d48327fe639 SHA512 36f11c207f391d06095dfab75fe4a638e562cd20bc29f72a6e5df1dcc87ab46f2834ffbdb561fb9e4e07fdd50dc5b34c619bbc4bc3d34ce350428e7330ea252c
+DIST visidata-2.1.1.tar.gz 952448 BLAKE2B c58378b9d653b50532f4f7209d08fbe4146a91907e7ca145580254784ea676b74554e9a8be69f7ae86842bf9548b16e28aa04fc8ecd42bfaee2f28e908cdddb9 SHA512 ade237622a1ac394fa2f287994c439330560062327b32a26adf129e3cae548a883ab1e76698233136aa6368b1823c4914e6912031c5b4221283d224ad2852bc7
diff --git a/app-office/visidata/visidata-2.1.1.ebuild b/app-office/visidata/visidata-2.1.1.ebuild
new file mode 100644
index 000000000..f1dc1c502
--- /dev/null
+++ b/app-office/visidata/visidata-2.1.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Terminal spreadsheet multitool for discovering and arranging data"
+HOMEPAGE="http://visidata.org"
+SRC_URI="https://github.com/saulpw/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/openpyxl[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-vcs/git
+ $(python_gen_impl_dep sqlite)
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/recommonmark \
+ dev-python/sphinx-argparse
+# dev-python/sphinx-markdown-tables
+
+python_prepare_all() {
+ rm tests/load-http.vd || die "Could not remove network-dependent test."
+ rm tests/graph-cursor-nosave.vd || die "Could not remove network-dependent test."
+ rm tests/messenger-nosave.vd || die "Could not remove network-dependent test."
+ rm tests/save-benchmarks.vd || die "Could not benchmarks test"
+ rm tests/graph-sincos-nosave.vd || die "Could not benchmarks test"
+ rm tests/graphpr-nosave.vd || die "Could not benchmarks test"
+ rm tests/describe-error.vd || die "Could not remove network-dependent test"
+ rm tests/describe.vd || die "Could not remove network-dependent test"
+ rm tests/edit-type.vd || die "Could not remove network-dependent test"
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ git init || die "Git init failed."
+ git add tests/golden/ || die "Git add failed."
+ dev/test.sh || die "Tests failed."
+ rm .git -rf || die "Could not clean up git test directory."
+}
+
+pkg_postinst() {
+ optfeature "integration with yaml" >=dev-python/pyyaml-5.1
+ optfeature "integration with pcap" dev-python/dnslib #dpkt pypcapkit
+ optfeature "integration with png" dev-python/pypng
+ optfeature "integration with http" dev-python/requests
+ optfeature "integration with postgres" dev-python/psycopg-binary
+ optfeature "integration with xlsx" dev-python/openpyxl
+ optfeature "integration with xls" dev-python/xlrd
+ optfeature "integration with hdf5" dev-python/h5py
+ optfeature "integration with ttf/otf" dev-python/fonttools
+ optfeature "integration with xml/htm/html" dev-python/lxml
+ optfeature "integration with dta (Stata)" dev-python/pandas
+ optfeature "integration with shapefiles" sci-libs/pyshp
+ optfeature "integration with namestand" dev-python/graphviz
+ optfeature "integration with pdfminer.six" dev-python/pdfminer-six # in guru
+ optfeature "integration with vobject" dev-python/vobject
+ optfeature "integration with tabulate" dev-python/tabulate
+ optfeature "integration with tabulate (with unicode)" dev-python/wcwidth
+ # optfeature "pdf tables" tabula # no package presently
+ #optfeature "integration with mbtiles" mapbox-vector-tile
+ #optfeature "integration with xpt (SAS)" xport
+ #optfeature "integration with sas7bdat (SAS)" sas7bdat
+ #optfeature "integration with sav (SPSS)" savReaderWriter
+}