aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorlayman <layman@localhost>2015-04-12 17:06:39 +0100
committerlayman <layman@localhost>2015-04-12 17:06:39 +0100
commite1b5c57763609c4498f50be71829d7e3c0f58b8c (patch)
treee0713c1ed6575c55e8eae889a61752de325b1d0a /sci-biology/bx-python/bx-python-0.7.2.ebuild
parentsci-biology/gffutils: add gffutils (diff)
downloadsci-e1b5c57763609c4498f50be71829d7e3c0f58b8c.tar.gz
sci-e1b5c57763609c4498f50be71829d7e3c0f58b8c.tar.bz2
sci-e1b5c57763609c4498f50be71829d7e3c0f58b8c.zip
sci-biology/bx-python: add bx-python
Package-Manager: portage-2.2.14-prefix
Diffstat (limited to 'sci-biology/bx-python/bx-python-0.7.2.ebuild')
-rw-r--r--sci-biology/bx-python/bx-python-0.7.2.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/sci-biology/bx-python/bx-python-0.7.2.ebuild b/sci-biology/bx-python/bx-python-0.7.2.ebuild
new file mode 100644
index 000000000..102c4d376
--- /dev/null
+++ b/sci-biology/bx-python/bx-python-0.7.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for rapid implementation of genome scale analyses. "
+HOMEPAGE="https://bitbucket.org/james_taylor/bx-python/wiki/Home"
+SRC_URI="mirror://pypi/b/bx-python/bx-python-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"