aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-25 17:25:55 +0200
committerJustin Lecher <jlec@gentoo.org>2011-06-25 17:25:55 +0200
commit8eae0874cf943ead6488e9f734faf40ee4bb3d99 (patch)
tree443e95be5b0fe018c5543850664d8cfaf814e697 /sci-biology/tclust/tclust-110625.ebuild
parentCleaned ebuild (diff)
downloadsci-8eae0874cf943ead6488e9f734faf40ee4bb3d99.tar.gz
sci-8eae0874cf943ead6488e9f734faf40ee4bb3d99.tar.bz2
sci-8eae0874cf943ead6488e9f734faf40ee4bb3d99.zip
Cleaned ebuild
(Portage version: 2.2.0_alpha41/git/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-biology/tclust/tclust-110625.ebuild')
-rw-r--r--sci-biology/tclust/tclust-110625.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-biology/tclust/tclust-110625.ebuild b/sci-biology/tclust/tclust-110625.ebuild
new file mode 100644
index 000000000..563cdabfb
--- /dev/null
+++ b/sci-biology/tclust/tclust-110625.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Transitive closure clustering tool with overlap filtering options"
+HOMEPAGE="http://compbio.dfci.harvard.edu/tgi/software/"
+SRC_URI="
+ ftp://occams.dfci.harvard.edu/pub/bio/tgi/software/tgicl/${PN}.tar.gz -> ${P}.tar.gz
+ ftp://occams.dfci.harvard.edu/pub/bio/tgi/software/tgicl/gclib.tar.gz -> gclib-${PV}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+ tc-export CC CXX
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README
+}