aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHonza Macháček <Hloupy.Honza@centrum.cz>2013-06-27 12:08:15 +0200
committerHonza Macháček <Hloupy.Honza@centrum.cz>2013-06-27 12:08:15 +0200
commitea52a973abf0f6b89edd392461ddce36624a1087 (patch)
tree927345153586e718ecded88021f53be4cd7f5e02 /sci-libs/bigdft-abi
parentmoved to gx86 (diff)
downloadsci-ea52a973abf0f6b89edd392461ddce36624a1087.tar.gz
sci-ea52a973abf0f6b89edd392461ddce36624a1087.tar.bz2
sci-ea52a973abf0f6b89edd392461ddce36624a1087.zip
In sci-libs/bigdft-abi-1.0.4-r1, CUDA support made compile.
Diffstat (limited to 'sci-libs/bigdft-abi')
-rw-r--r--sci-libs/bigdft-abi/ChangeLog8
-rw-r--r--sci-libs/bigdft-abi/bigdft-abi-1.0.4-r1.ebuild (renamed from sci-libs/bigdft-abi/bigdft-abi-1.0.4.ebuild)3
-rw-r--r--sci-libs/bigdft-abi/files/bigdft-abi-1.0.4-CUDA_gethostname.patch22
3 files changed, 33 insertions, 0 deletions
diff --git a/sci-libs/bigdft-abi/ChangeLog b/sci-libs/bigdft-abi/ChangeLog
index 8b17f1fa5..b1fc75cb5 100644
--- a/sci-libs/bigdft-abi/ChangeLog
+++ b/sci-libs/bigdft-abi/ChangeLog
@@ -2,6 +2,14 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*bigdft-abi-1.0.4-r1 (27 Jun 2013)
+
+ 27 Jun 2013; Honza Macháček <Hloupy.Honza@centrum.cz>
+ -bigdft-abi-1.0.4.ebuild, +bigdft-abi-1.0.4-r1.ebuild,
+ +files/bigdft-abi-1.0.4-CUDA_gethostname.patch:
+ Added #include <unistd.h> to S_GPU/src/class_utils.h and
+ src/CUDA/check_cuda.h to know gethostname.
+
19 Jun 2013; Honza Macháček <Hloupy.Honza@centrum.cz>
bigdft-abi-1.0.4.ebuild:
Filter LDFLAGS for cuda use not to break nvcc.
diff --git a/sci-libs/bigdft-abi/bigdft-abi-1.0.4.ebuild b/sci-libs/bigdft-abi/bigdft-abi-1.0.4-r1.ebuild
index 51f1e48c6..f466e9078 100644
--- a/sci-libs/bigdft-abi/bigdft-abi-1.0.4.ebuild
+++ b/sci-libs/bigdft-abi/bigdft-abi-1.0.4-r1.ebuild
@@ -76,6 +76,9 @@ pkg_setup() {
}
src_prepare() {
+ epatch \
+ "${FILESDIR}"/"${P}"-CUDA_gethostname.patch
+
tar -xjf "${FILESDIR}"/"${P}"-tests.tar.bz2 -C "${S}"/tests/DFT/
eautoreconf
}
diff --git a/sci-libs/bigdft-abi/files/bigdft-abi-1.0.4-CUDA_gethostname.patch b/sci-libs/bigdft-abi/files/bigdft-abi-1.0.4-CUDA_gethostname.patch
new file mode 100644
index 000000000..04c45b4d7
--- /dev/null
+++ b/sci-libs/bigdft-abi/files/bigdft-abi-1.0.4-CUDA_gethostname.patch
@@ -0,0 +1,22 @@
+diff -Naurp bigdft-abi-1.0.4-orig/S_GPU/src/class_utils.h bigdft-abi-1.0.4/S_GPU/src/class_utils.h
+--- bigdft-abi-1.0.4-orig/S_GPU/src/class_utils.h 2012-07-09 14:43:33.000000000 +0000
++++ bigdft-abi-1.0.4/S_GPU/src/class_utils.h 2013-06-27 09:52:17.000000000 +0000
+@@ -32,6 +32,7 @@
+ #include <config.h>
+ #endif
+
++#include <unistd.h>
+ #include <sstream>
+
+ class deleter
+diff -Naurp bigdft-abi-1.0.4-orig/src/CUDA/check_cuda.h bigdft-abi-1.0.4/src/CUDA/check_cuda.h
+--- bigdft-abi-1.0.4-orig/src/CUDA/check_cuda.h 2012-07-09 14:43:33.000000000 +0000
++++ bigdft-abi-1.0.4/src/CUDA/check_cuda.h 2013-06-27 09:51:50.000000000 +0000
+@@ -1,6 +1,7 @@
+ #ifndef __checkcuda__
+ #define __checkcuda__
+
++#include <unistd.h>
+ #include <string>
+ #include <sstream>
+