aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-01-17 13:37:24 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2015-01-17 13:37:24 +0100
commitc6eb39ae487c5ba48e633e087af589c2a952747a (patch)
tree24d65e40880dd41c5867ca8fa5fc57f868fbf396 /sci-libs/factory
parentsci-libs/factory: Move to EAPI=5 (diff)
downloadsci-c6eb39ae487c5ba48e633e087af589c2a952747a.tar.gz
sci-c6eb39ae487c5ba48e633e087af589c2a952747a.tar.bz2
sci-c6eb39ae487c5ba48e633e087af589c2a952747a.zip
Add sci-libs/factory-3.1.1-r2 with support for static-libs use flag
Diffstat (limited to 'sci-libs/factory')
-rw-r--r--sci-libs/factory/ChangeLog9
-rw-r--r--sci-libs/factory/factory-3.1.1-r2.ebuild47
2 files changed, 55 insertions, 1 deletions
diff --git a/sci-libs/factory/ChangeLog b/sci-libs/factory/ChangeLog
index f8ef98577..523d745db 100644
--- a/sci-libs/factory/ChangeLog
+++ b/sci-libs/factory/ChangeLog
@@ -1,7 +1,14 @@
# ChangeLog for sci-libs/factory
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*factory-3.1.1-r2 (17 Jan 2015)
+
+ 17 Jan 2015; Marius Brehler <marbre@linux.sungazer.de>
+ -factory-3.1.1.ebuild, factory-3.1.1-r1.ebuild, +factory-3.1.1-r2.ebuild:
+ Add 3.1.1-r2 with support for static-libs use flag;
+ Move 3.1.1-r1 to EAPI=5 and drop 3.1.1
+
*factory-3.1.1-r1 (04 Sep 2010)
04 Sep 2010; François Bissey <f.r.bissey@massey.ac.nz>
diff --git a/sci-libs/factory/factory-3.1.1-r2.ebuild b/sci-libs/factory/factory-3.1.1-r2.ebuild
new file mode 100644
index 000000000..a549a75c8
--- /dev/null
+++ b/sci-libs/factory/factory-3.1.1-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit autotools-utils versionator
+
+MY_PV=$(replace_all_version_separators '-')
+
+DESCRIPTION="C++ library for representing multivariate polynomials"
+HOMEPAGE="http://www.mathematik.uni-kl.de/pub/Math/Singular/Factory"
+SRC_URI="ftp://www.mathematik.uni-kl.de/pub/Math/Singular/Factory/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+IUSE="singular static-libs"
+
+DEPEND="dev-libs/gmp
+ >=dev-libs/ntl-5.4.1"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+AUTOTOOLS_IN_SOURCE_BUILD="1"
+DOCS=( README NEWS )
+PATCHES=( "${FILESDIR}"/${P}-gentoo.diff )
+
+pkg_setup() {
+ tc-export CC CPP CXX
+}
+
+src_configure() {
+ myeconfargs=( $(use_with singular Singular) )
+
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ # We cannot disable the build of static libs, so delete after installed to ${D}
+ if ! use static-libs; then
+ find "${D}" -type f -name "*.a" -delete || die
+ fi
+}