aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorlayman <layman@localhost>2015-09-12 13:54:43 +0100
committerlayman <layman@localhost>2015-09-12 22:34:29 +0100
commit0b3f38a08d320d1d460ae9d2f93076c7ff1ec84c (patch)
tree7e0d3b8e3c3f66e14a68a2bd9bd04e8f47f190f3 /sci-libs/symengine
parentMerge branch 'master' into symengine (diff)
downloadsci-0b3f38a08d320d1d460ae9d2f93076c7ff1ec84c.tar.gz
sci-0b3f38a08d320d1d460ae9d2f93076c7ff1ec84c.tar.bz2
sci-0b3f38a08d320d1d460ae9d2f93076c7ff1ec84c.zip
sci-libs/symengine: cleaning up syntax; remove openmpi dep
Package-Manager: portage-2.2.20-prefix
Diffstat (limited to 'sci-libs/symengine')
-rw-r--r--sci-libs/symengine/symengine-0.1.0.ebuild11
-rw-r--r--sci-libs/symengine/symengine-9999.ebuild12
2 files changed, 8 insertions, 15 deletions
diff --git a/sci-libs/symengine/symengine-0.1.0.ebuild b/sci-libs/symengine/symengine-0.1.0.ebuild
index cc464d18b..8f549eebe 100644
--- a/sci-libs/symengine/symengine-0.1.0.ebuild
+++ b/sci-libs/symengine/symengine-0.1.0.ebuild
@@ -23,7 +23,6 @@ RDEPEND="
boost? ( dev-libs/boost )
python? ( dev-python/numpy[${PYTHON_USEDEP}] )"
DEPEND="${RDEPEND}
- openmp? ( sys-cluster/openmpi )
python? (
dev-python/cython[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}] )"
@@ -31,12 +30,10 @@ DEPEND="${RDEPEND}
CMAKE_BUILD_TYPE=Release
pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- if use openmp; then
- if [[ $(tc-getCC) == *gcc ]] && ! tc-has-openmp; then
- ewarn "OpenMP is not available in your current selected gcc"
- die "need openmp capable gcc"
- fi
+ if use openmp && [[ ${MERGE_TYPE} != binary ]]; then
+ if [[ $(tc-getCC) == *gcc ]] && ! tc-has-openmp; then
+ ewarn "OpenMP is not available in your current selected gcc"
+ die "need openmp capable gcc"
fi
fi
}
diff --git a/sci-libs/symengine/symengine-9999.ebuild b/sci-libs/symengine/symengine-9999.ebuild
index 29497165a..9e6ab5376 100644
--- a/sci-libs/symengine/symengine-9999.ebuild
+++ b/sci-libs/symengine/symengine-9999.ebuild
@@ -24,21 +24,17 @@ RDEPEND="
boost? ( dev-libs/boost )
python? ( dev-python/numpy[${PYTHON_USEDEP}] )"
DEPEND="${RDEPEND}
- openmp? ( sys-cluster/openmpi )
python? (
dev-python/cython[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}] )"
-
CMAKE_BUILD_TYPE=Release
pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- if use openmp; then
- if [[ $(tc-getCC) == *gcc ]] && ! tc-has-openmp; then
- ewarn "OpenMP is not available in your current selected gcc"
- die "need openmp capable gcc"
- fi
+ if use openmp && [[ ${MERGE_TYPE} != binary ]]; then
+ if [[ $(tc-getCC) == *gcc ]] && ! tc-has-openmp; then
+ ewarn "OpenMP is not available in your current selected gcc"
+ die "need openmp capable gcc"
fi
fi
}