aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Kerr <cjk34@cam.ac.uk>2013-07-01 13:10:38 +0100
committerChris Kerr <cjk34@cam.ac.uk>2013-07-01 13:10:38 +0100
commit91e3f6c389cc9d273751b3eae3800e749876ec66 (patch)
tree230a1795d33a6fc7aeca3eeb96e3a810bedef561 /sys-cluster
parentNow everything is going in /usr/usr/whatever - trying setting PREFIX to / (diff)
parentsci-libs/msms: Version BUmp; Bump to new distutil-r1.eclass (diff)
downloadsci-91e3f6c389cc9d273751b3eae3800e749876ec66.tar.gz
sci-91e3f6c389cc9d273751b3eae3800e749876ec66.tar.bz2
sci-91e3f6c389cc9d273751b3eae3800e749876ec66.zip
Merge branch 'master' of https://github.com/gentoo-science/sci into HTCondor
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/hpl/ChangeLog8
-rw-r--r--sys-cluster/hpl/Manifest3
-rw-r--r--sys-cluster/hpl/hpl-2.1.ebuild71
3 files changed, 81 insertions, 1 deletions
diff --git a/sys-cluster/hpl/ChangeLog b/sys-cluster/hpl/ChangeLog
index b061ae1b1..9a1784a3b 100644
--- a/sys-cluster/hpl/ChangeLog
+++ b/sys-cluster/hpl/ChangeLog
@@ -2,6 +2,14 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*hpl-2.1 (29 Jun 2013)
+
+ 29 Jun 2013; Andrew Savchenko <bircoph@gmail.com> +hpl-2.1.ebuild:
+ Version bump.
+ Fix bug 452984 (use system CFLAGS).
+ Install HPL.dat properly.
+ Import ebuild improvements from portage.
+
03 Mar 2013; Justin Lecher <jlec@gentoo.org> hpl-2.0-r1.ebuild:
Sort *DEPEND correctly
diff --git a/sys-cluster/hpl/Manifest b/sys-cluster/hpl/Manifest
index 21c146598..86c4ee494 100644
--- a/sys-cluster/hpl/Manifest
+++ b/sys-cluster/hpl/Manifest
@@ -1 +1,2 @@
-DIST hpl-2.0.tar.gz 591087 SHA256 d8d118c310d34a5a2acf5a689270a9f7bea60245552d24af8641599651909bec
+DIST hpl-2.0.tar.gz 591087 SHA256 d8d118c310d34a5a2acf5a689270a9f7bea60245552d24af8641599651909bec SHA512 3aa76144526b01ec40d940cae50d47e480e2760a36d1e95bc6e431b216407db190946fc3d99a6a7caf7b61bcc76d805d28da3ef0b141ff467854e1cdf10bb274 WHIRLPOOL 79da0950089d8e7d6128a2af7a44de704c2666aeb74de08e9e0a06fc23f8c4d17da2ab5107b5f6a82ca073800ec2af4f003c7792ae84e1ec032d9572e78bc0b2
+DIST hpl-2.1.tar.gz 527433 SHA256 dd437dd34a098c51092319983addff1d8076fc8dd692d19c488252477363af15 SHA512 ed39e407341d1cfe2d4d7e50f029e3ca62c7e87e82c3b09a89fd231c5cb4f1c95857f050a940bfd60b724eaa9fdab8631a0693a14b6e9dac82c05897bff557a4 WHIRLPOOL 7e0ff3132590869cff9366c3e34d1abcbfc2be6fceccd336785ce680412981bde658fb67a3663235e15b432c7e0b7e95b79296029d051dbccec239c0c960ae20
diff --git a/sys-cluster/hpl/hpl-2.1.ebuild b/sys-cluster/hpl/hpl-2.1.ebuild
new file mode 100644
index 000000000..ac066244b
--- /dev/null
+++ b/sys-cluster/hpl/hpl-2.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/hpl/hpl-2.0-r2.ebuild,v 1.1 2013/02/27 15:57:37 jlec Exp $
+
+EAPI=5
+
+inherit eutils mpi multilib
+
+DESCRIPTION="A Portable Implementation of the High-Performance Linpack Benchmark for Distributed-Memory Computers"
+HOMEPAGE="http://www.netlib.org/benchmark/hpl/"
+SRC_URI="http://www.netlib.org/benchmark/hpl/hpl-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="HPL"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc"
+
+RDEPEND="
+ $(mpi_pkg_deplist)
+ virtual/blas
+ virtual/lapack"
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ local mpicc_path="$(mpi_pkg_cc)"
+ local a=""
+ local locallib="${EPREFIX}/usr/$(get_libdir)/lib"
+ local localblas="$(for i in $($(tc-getPKG_CONFIG) --libs-only-l blas lapack);do a="${a} ${i/-l/${locallib}}.so "; done; echo ${a})"
+
+ cp setup/Make.Linux_PII_FBLAS Make.gentoo_hpl_fblas_x86 || die
+ sed -i \
+ -e "/^TOPdir/s,= .*,= ${S}," \
+ -e '/^HPL_OPTS\>/s,=,= -DHPL_DETAILED_TIMING -DHPL_COPY_L,' \
+ -e '/^ARCH\>/s,= .*,= gentoo_hpl_fblas_x86,' \
+ -e '/^MPdir\>/s,= .*,=,' \
+ -e '/^MPlib\>/s,= .*,=,' \
+ -e "/^LAlib\>/s,= .*,= ${localblas}," \
+ -e "/^LINKER\>/s,= .*,= ${mpicc_path}," \
+ -e "/^CC\>/s,= .*,= ${mpicc_path}," \
+ -e "/^CCFLAGS\>/s|= .*|= \$(HPL_DEFS) ${CFLAGS}|" \
+ -e "/^LINKFLAGS\>/s|= .*|= ${LDFLAGS}|" \
+ Make.gentoo_hpl_fblas_x86 || die
+}
+
+src_compile() {
+ mpi_pkg_set_env
+ # parallel make failure bug #321539
+ HOME=${WORKDIR} emake -j1 arch=gentoo_hpl_fblas_x86
+ mpi_pkg_restore_env
+}
+
+src_install() {
+ mpi_dobin bin/gentoo_hpl_fblas_x86/xhpl
+ mpi_dolib.a lib/gentoo_hpl_fblas_x86/libhpl.a
+ mpi_dodoc INSTALL BUGS COPYRIGHT HISTORY README TUNING
+ mpi_doman man/man3/*.3
+ if use doc; then
+ mpi_dohtml -r www/*
+ fi
+ insinto $(mpi_root)usr/share/hpl
+ mpi_doins bin/gentoo_hpl_fblas_x86/HPL.dat
+}
+
+pkg_postinst() {
+ local d=$(mpi_root)
+ einfo "Remember to copy $(mpi_root)usr/share/hpl/HPL.dat to your working directory"
+ einfo "before running xhpl. Typically one may run hpl by executing:"
+ einfo "\"mpiexec -np 4 /usr/bin/xhpl\""
+ einfo "where -np specifies the number of processes."
+}