aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-physics/rivet/ChangeLog7
-rw-r--r--sci-physics/rivet/Manifest1
-rw-r--r--sci-physics/rivet/rivet-2.3.0.ebuild60
-rw-r--r--sci-physics/yoda/ChangeLog7
-rw-r--r--sci-physics/yoda/Manifest1
-rw-r--r--sci-physics/yoda/metadata.xml1
-rw-r--r--sci-physics/yoda/yoda-1.4.0.ebuild51
7 files changed, 126 insertions, 2 deletions
diff --git a/sci-physics/rivet/ChangeLog b/sci-physics/rivet/ChangeLog
index fe6ccee23..65033b736 100644
--- a/sci-physics/rivet/ChangeLog
+++ b/sci-physics/rivet/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for sci-physics/rivet
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*rivet-2.3.0 (15 Aug 2015)
+
+ 15 Aug 2015; Jauhien Piatlicki <jauhien@gentoo.org> +rivet-2.3.0.ebuild:
+ version bump
+
*rivet-2.1.2 (05 Sep 2014)
05 Sep 2014; Jauhien Piatlicki <jauhien@gentoo.org> +rivet-2.1.2.ebuild:
diff --git a/sci-physics/rivet/Manifest b/sci-physics/rivet/Manifest
index 9af9cc9d1..8719b1dd1 100644
--- a/sci-physics/rivet/Manifest
+++ b/sci-physics/rivet/Manifest
@@ -1,2 +1,3 @@
DIST Rivet-2.1.1.tar.bz2 4084261 SHA256 eefa936de6f6c34a6bab39899841f3189d7621c8ba227032f0f32e6e20dfcf85 SHA512 ee1ed8741b539aa773ba7ef9b704bfe0cc5aa1683ad2f4eac5cffc798ac989f041383e38852afb0353a59bdf887bb24c1491407ad4a5f68700c481b5e8008ebf WHIRLPOOL 1ee7cd016cc6ab3a843edc1655dce4bfc251e96bffdc157bda653204e99e997f6f23427af654bb8914314b82103502674fd89637c2acf72529bf7976fb707aaf
DIST Rivet-2.1.2.tar.bz2 4101565 SHA256 40a20c1ee186326e5bfd906e0bc88f16dc740551be9cc274e9a826873d9c1eed SHA512 d3f8078c7131c173f64c97466ac7e8b2fd559a2c5ae5c8366ba2735fa71aab3a490b9d0a7af614be4f858698f9fa56bca50043f690227ab62128583964e1107d WHIRLPOOL 16a51d102b7834ec29e9088d4183135daa4e7237a31d0df7e0f4b7b7e46090df235363850a776946e700266e024d100864c83b3a94285266c7ba7b584bd78b7a
+DIST Rivet-2.3.0.tar.bz2 2742948 SHA256 dd07702981d586e4b97b0fa56ae08cd08a631a952322a9b52e7622a46a7741ab SHA512 b51b77f80d69156dead899312cad838bc03479a072e163df50262e86790503515f8ab8af93723c3cbd33007d9812aa10581b2c960d92bc1fcf5031d27018d239 WHIRLPOOL ce9e5dd34ba9b53de192aee39bcd94565a62a328bd35dcb1ef810cc7b129e9ae6529fc8f970889f7a6970567bdd0f040d15fc5bbb83ec22e38daccb34cbb4fdf
diff --git a/sci-physics/rivet/rivet-2.3.0.ebuild b/sci-physics/rivet/rivet-2.3.0.ebuild
new file mode 100644
index 000000000..c6fd8060a
--- /dev/null
+++ b/sci-physics/rivet/rivet-2.3.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+AUTOTOOLS_AUTORECONF=1
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 autotools-utils bash-completion-r1
+
+MYP=Rivet-${PV}
+
+DESCRIPTION="Toolkit for validation of Monte Carlo HEP event generators"
+HOMEPAGE="http://rivet.hepforge.org/"
+
+SRC_URI="http://www.hepforge.org/archive/${PN}/${MYP}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc python static-libs"
+
+RDEPEND="
+ dev-libs/boost:0=
+ sci-libs/gsl:0=
+ sci-physics/fastjet:0=[plugins]
+ sci-physics/hepmc:0=
+ sci-physics/yoda:0=[python]
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[latex,dot] )
+ python? ( dev-python/cython[${PYTHON_USEDEP}] )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+S="${WORKDIR}/${MYP}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable python pyext)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && doxygen Doxyfile
+}
+
+src_install() {
+ autotools-utils_src_install
+ newbashcomp "${ED}"/usr/share/Rivet/rivet-completion rivet
+ use doc && dohtml -r doxy/html/* && dodoc doc/rivet-manual.pdf
+}
diff --git a/sci-physics/yoda/ChangeLog b/sci-physics/yoda/ChangeLog
index 72d87df97..9bba03c9f 100644
--- a/sci-physics/yoda/ChangeLog
+++ b/sci-physics/yoda/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for sci-physics/yoda
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*yoda-1.4.0 (15 Aug 2015)
+
+ 15 Aug 2015; Jauhien Piatlicki <jauhien@gentoo.org> +yoda-1.4.0.ebuild:
+ version bump
+
*yoda-1.0.6 (06 May 2014)
06 May 2014; SĂ©bastien Fabbro <bicatali@gentoo.org> +metadata.xml,
diff --git a/sci-physics/yoda/Manifest b/sci-physics/yoda/Manifest
index 6e5b4038b..c889926c0 100644
--- a/sci-physics/yoda/Manifest
+++ b/sci-physics/yoda/Manifest
@@ -1 +1,2 @@
DIST YODA-1.0.6.tar.bz2 689998 SHA256 357732448d67a593e5ff004418f2a2a263a1401ffe84e021f8a714aa183eaa21 SHA512 e0e63d30259d0d5cf7589e7228ea80b029683832058930a79d4be532535e96504c0362d28881503fb98f9fd7ab6721d4975681464e24294ae55cd47dc671873f WHIRLPOOL 5214f0e961380708d600d04f058a2a29286a933b02d5dc33fa472c63a38414cd1ca5104d8dd1e6dd8cc78e16bad85a61bc1b9b47b1326d214e8439b133d1b521
+DIST YODA-1.4.0.tar.bz2 809432 SHA256 e76a129f7c2b72b53525fe0b712606eeeab0dc145daa070ebf0728f0384eaf48 SHA512 f1873888f3d2c28d42ac54fa9f3fa4a98e648a638ebceffce0a2f742c5fb6647fabd0de49c00407741e937600fc8a12d33ca26b8b9cd9b81c28a4d2e11f2bd3a WHIRLPOOL 6c8e0176b729d951351b3b9d574c91add5d6302aa76417241e560f3f3bbf38f4b60f41713d89a03a62b1c4ad3a98bd5342fd05901671e6aedf0c2c11dc36b024
diff --git a/sci-physics/yoda/metadata.xml b/sci-physics/yoda/metadata.xml
index d573312d1..b221b3a12 100644
--- a/sci-physics/yoda/metadata.xml
+++ b/sci-physics/yoda/metadata.xml
@@ -10,6 +10,7 @@
in Rivet.
</longdescription>
<use>
+ <flag name="c++11"> Build using the C++11 standard</flag>
<flag name='root'>Adds support for <pkg>sci-physics/root</pkg></flag>
</use>
</pkgmetadata>
diff --git a/sci-physics/yoda/yoda-1.4.0.ebuild b/sci-physics/yoda/yoda-1.4.0.ebuild
new file mode 100644
index 000000000..32e5bf37a
--- /dev/null
+++ b/sci-physics/yoda/yoda-1.4.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 autotools-utils bash-completion-r1
+
+MYP=YODA-${PV}
+
+DESCRIPTION="Yet more Objects for (High Energy Physics) Data Analysis"
+HOMEPAGE="http://yoda.hepforge.org/"
+
+SRC_URI="http://www.hepforge.org/archive/${PN}/${MYP}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="c++11 python root static-libs"
+
+RDEPEND="
+ dev-libs/boost:0=
+ python? ( ${PYTHON_DEPS} )
+ root? ( sci-physics/root:0=[python=,${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ python? ( dev-python/cython[${PYTHON_USEDEP}] )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+S="${WORKDIR}/${MYP}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable c++11 stdcxx11)
+ $(use_enable python pyext)
+ $(use_enable root)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ newbashcomp "${ED}"/usr/share/YODA/yoda-completion yoda
+}