aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/castxml/castxml-0.0.0_pre9.ebuild')
-rw-r--r--dev-cpp/castxml/castxml-0.0.0_pre9.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-cpp/castxml/castxml-0.0.0_pre9.ebuild b/dev-cpp/castxml/castxml-0.0.0_pre9.ebuild
new file mode 100644
index 000000000..a6046f2a6
--- /dev/null
+++ b/dev-cpp/castxml/castxml-0.0.0_pre9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils git-r3 llvm
+
+MY_PN="CastXML"
+
+DESCRIPTION="CastXML is a C-family abstract syntax tree XML output tool."
+HOMEPAGE="https://github.com/CastXML/CastXML"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/gerddie/CastXML"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="${RDEPEND}"
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/libxml2
+ sys-devel/llvm:=
+ sys-devel/clang:=
+ "
+
+src_test() {
+ cd "${BUILD_DIR}" || die
+ ctest -j 20
+}